PS4 & PFSense



  • Howdy Folks,

    I'm still new to pfSense and recently got my network somewhat setup. I'm getting the good ole NAT type 3 issue when connecting my PS4 via wireless or through an ethernet cable. I am currently also running Snort, but I checked and it is still in detect mode. Below is my current topology:

    ISP -> Netgear Modem -> pfSense with two ports (one to the modem, one to the router) -> Netgear Router (Being used as a router and not an AP) -> Ethernet cable connection to PS4. My WAN interface has a 1 public IP and the LAN is the standard 192.168.1.0/24. When I setup the router after the pfSense firewall, my Netgear router and everything attached to it is on the 10.0.0.0/24 subnet. It gave me a notice and said it did this automatically so there wouldn't be an issue with my ISP?

    I've looked up videos and trying to do some searching to resolve the issue and this is what I've tried:

    • Enabled UPNP on the router
    • Port forwarded all of the recommended ports at the router by the IP of my PS4
    • Enabled UPNP on pfSense by Services -> UPnP & NAT-PMP -> Enabled these three options: Enable UPnP & NAT-PMP, UPnP Port Mapping, NAT-PMP Port Mapping

    Any recommendations on what to try next? Is this an example of a double NAT? I've read something about DMZing the PS4, but that really isn't an option right now with my topology and I'd rather not have it exposed due to security reasons.


  • LAYER 8 Moderator

    @Defensive_Roots said in PS4 & PFSense:

    I'm getting the good ole NAT type 3 issue

    You'll always get NAT type 3 without uPNP / ports redirected to the console. That's normal.

    Don't understand what you are doing with that Netcrap Router behind pfSense in front of your PS4 though. Why not simply running it as AP only without any routing? What are you trying to gain by that? Makes no sense to me.



  • I thought that having a direct wired connection would be more reliable to the PS4. Probably a poor assumption on my part as I’m still learning.

    I enabled UPNP on both pfSense and the router. Still type 3 error.

    Is what your suggesting to put the router in AP mode and see if that works? Would I still be able to run a cable the same way or would it have to be wireless only?

    Btw, thanks for the help 😀


  • LAYER 8 Moderator

    @Defensive_Roots said in PS4 & PFSense:

    I thought that having a direct wired connection would be more reliable to the PS4. Probably a poor assumption on my part as I’m still learning.

    I'd still recommend it. Our younglings only have their console attached to cable besides having good WiFi coverage. Latency and connection is much better. But that doesn't explain what that router has to do in between?

    I enabled UPNP on both pfSense and the router. Still type 3 error.

    uPNP makes no sense if you have another router in the mix.

    • remove Netgear router -> replace with cable to switch/pfsense
    • setup console to get a static/semi static (dhcp fixed) address
    • setup uPNP to work only for that fixed PS4 IP so that's the only device that gets served

    as you write pfSense is connected via Modem, it should have a public IP so after setting this up like above, the PS4 should be able to make calls to the upnp daemon to make port forwards on demand and you should get NAT type 2 with ease. Working with 4 consoles here (even though all play-gear is separated in its own VLAN here).



  • @JeGr So essentially I can put a managed switch between the pfSense and the router. Have the PS4 run off of the switch which would take the router out of the equation and just leave my other wireless devices behind the router?



  • Hi all,

    I got it working now. I put the router into AP mode instead of router which gave it a 192.168.1.0/24 address instead of a 10...*/24 address. After that, I set up a static IP and changed the NAT type to hybrid for the specified IP. Mods, please feel free to close the post as I should have read the pinned thread to begin with.


Log in to reply