igbX bug TX(1) desc avail - no carrier


  • LAYER 8

    i have a problem with my intel network card now, it just stop responding and start to print multiple line with

    igb0: TX(1) desc avail = 41, pidx = 440
    

    it could be related to this bug?
    https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=239240

    i need to restart pfsense to bring it up again.
    intel i350
    interface show "status: no carrier"

    Version 2.5.0-DEVELOPMENT (amd64)
    built on Wed Jan 08 07:46:13 EST 2020
    FreeBSD 12.0-RELEASE-p10

    how to reproduce:
    remove the network cable, wait some times, reconnect the cable
    or
    in my specific case i turned off and on the modem that is connected on my igb0 interface


  • Rebel Alliance Developer Netgate

    It could be related. At some point in the near future we are going to move 2.5.0 to a 12-STABLE base so it should pick that up once we make the shift. No ETA on that. We're focused on 2.4.5 at the moment.



  • I just ran into this myself. Here is an interesting tid-bit. This only appears to affect connections negotiated at 10/100. Gigabit connections appear to be just fine. I have this issue between my i350 based pfsense box and my ISP NID which is just a glorified media converter. Stick a gigabit switch in between them live and the link comes right up. I have to completely power off my box to fix this issue. Took some trial an error to nail down the exact sequence to fix. Soon I will try to replicate on a Cisco and maybe a Juniper with 10/100 ports. Another side note is that Ubuntu 18.04 appears to have the same bug. Sure hope it's not a chipset issue.



  • Sorry to reply to myself but just found this in the debian forums for the same issue. Perhaps it's a simple power control setting in the bsd driver that is disabling the NIC?


    Message #26 received at 928328@bugs.debian.org (full text, mbox, reply):
    From: "Rene 'Renne' Bartsch, B.Sc. Informatics" rene@bartschnet.de
    To: 928328@bugs.debian.org
    Subject: Re: Intel I350-NIC shuts down ports after loosing carrier
    Date: Fri, 3 May 2019 11:01:42 +0200

    echo on > /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/power/control
    echo on > /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.1/power/control
    echo on > /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.2/power/control
    echo on > /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.3/power/control

    solves the problem. This should be "on" by default instead of "auto".

    Regards,

    Renne


Log in to reply