FRR OSPF Ext 1 Default Route With Unexpected Cost.



  • Hi. I configured FRR OSPFv2 to advertise an ext type 1 default route with a cost of 50. If I reset ospfd the LSA will show a cost of 50 but eventually the cost changes to 70. I'm at my wits end here. Can anybody spot anything in my config that would cause this behavior? Thanks.

    Here is my config:

    zebra.conf:

    ##################### DO NOT EDIT THIS FILE! ######################
    ###################################################################

    This file was created by an automatic configuration generator.

    The contents of this file will be overwritten without warning!

    ###################################################################
    password ********

    Accept Filters

    ip prefix-list ACCEPTFILTER deny 10.254.6.20/30
    ip prefix-list ACCEPTFILTER deny 10.254.6.22/32
    ip prefix-list ACCEPTFILTER deny 0.0.0.0/0
    ip prefix-list ACCEPTFILTER deny ::/0
    ip prefix-list ACCEPTFILTER permit any
    route-map ACCEPTFILTER permit 10
    match ip address prefix-list ACCEPTFILTER
    ip protocol ospf route-map ACCEPTFILTER

    ospfd.conf:

    ##################### DO NOT EDIT THIS FILE! ######################
    ###################################################################

    This file was created by an automatic configuration generator.

    The contents of this file will be overwritten without warning!

    ###################################################################
    password ********
    interface hn0
    ip ospf network broadcast
    ip ospf cost 1
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 ********
    ip ospf priority 1
    ip ospf mtu-ignore
    ip ospf area 0.0.0.10
    interface hn0.10
    ip ospf cost 1
    ip ospf area 0.0.0.10
    interface hn3
    ip ospf cost 1
    ip ospf area 0.0.0.10
    interface ovpnc1
    ip ospf network point-to-point
    ip ospf cost 30
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 ********
    ip ospf dead-interval 20
    ip ospf hello-interval 5
    ip ospf area 0.0.0.10

    router ospf
    ospf router-id 10.255.255.6
    area 0.0.0.10 shortcut default
    area 0.0.0.10 authentication message-digest
    default-information originate metric 50 metric-type 1
    ospf abr-type cisco
    passive-interface hn0.10
    passive-interface hn3



  • @0daymaster said in FRR OSPF Ext 1 Default Route With Unexpected Cost.:

    default-information originate metric 50 metric-type 1

    You can try to change metric-type 1 to metric-type 2 which is the default. It shouldnt change the costs then... as far as i understand that metric-type ...


Log in to reply