[SOLVED] Public IP address has not changed



  • Hello everyone,

    I'm hoping someone can help/explain why I am receiving the error message below:

    Screen Shot 2020-02-03 at 1.50.45 PM.jpg

    I have setup my VPN and connect to it fine, however if I do not have "Redirect IPv4 Gateway Force all client-generated IPv4 traffic through the tunnel" enabled I get that error. If enabled on pfSense or in Viscosity, no error message. I would prefer to have IPv4 traffic destined for my home network to be routed thru the tunnel and any other traffic to not go thru the tunnel. What am I missing? If you need any other info, let me know and I will gladly post.

    BTW, I have DNS servers for the VPN server set as the IP address of my pfSense and also 8.8.8.8 as the second DNS server. If I have 8.8.8.8 set as the second DNS server, I cannot ping any of the hosts on my LAN. When 8.8.8.8 is removed, I can ping hosts. Thanks for any info/help you can provide.



  • @simon_lefisch said in Public IP address has not changed:

    however if I do not have "Redirect IPv4 Gateway Force all client-generated IPv4 traffic through the tunnel" enabled I get that error.

    So it does what you told it to do.
    Not all traffic gets directed to the tunnel. The test you showed didn't take the tunnel, and thus it shwos a warning (is not an error).

    @simon_lefisch said in Public IP address has not changed:

    I would prefer to have IPv4 traffic destined for my home network to be routed thru the tunnel and any other traffic to not go thru the tunnel. What am I missing?
    Your missing "the test to check your apparent public IP" did not take the tunnel.
    If it would know that behind the tunnel another gateway is available, and using that one will show another IP for sure ...
    ( don't ask me how to do so .... I'm just "Redirect IPv4 / IPv6 Gateway force .... " and call it a day )

    As long as you can access your home network - and access the Internet without using the VPN connection to home - then all is well, right ?



  • @Gertjan you are correct. I will just set everything to go thru the tunnel and be done with it. Thanks for pointing these things out.


Log in to reply