Can't renew with updated/changed validation method



  • I tried search but can't find any answer.

    The initial configuration was done when port 80 was blocked. I managed to get it working with 'tls-alpn-01'.

    Yesterday the port 80 was open. I update the config to use 'Standalone HTTP Server'. Added the rule to allow port 80.

    However I got the error message "Error, can not get domain token entry ..."
    "The supported validation types are: tls-alpn-01 , but you specified: http-01".

    Still new to this. Are there anything I can do to switch the new validation method? Assuming waiting for the expiration of the cert is not the option.

    Thank you very much.



  • Hi!

    I have the same thing but different validations.
    Originally done it via http-01 and switched to dns-01 (dnsupdate).
    Now I`m getting "The supported validation types are: http-01 , but you specified: dns-01".

    Tried deleting and re-adding config but everytime the same.
    I think this is LE quirk and as soon as validation will expire on their servers, we will be able to issue a cert using changed validation method.

    Anyone else?



  • The reply from LE forum is indicating it is a bug of acme.sh.



  • It is fixed: https://github.com/acmesh-official/acme.sh/commit/4f303de00c8d640351db5fb065bf0861786fab18

    We need to wait for offical release (2.8.6).

    Or you can copy acme.sh from master branch it will work as well.


Log in to reply