Problem after deleting Target Category



  • Hey Guys,

    I had created a specific target category ("YoutubeLiberados") for a test which consisted in allowing a couple of youtube URLs.

    I then hit apply and performed the tests.

    After that I removed the target categories and hit apply again, but when I did that the following errors appeared:

    04.02.2020 19:39:02 [sg_create_config] Error Terminated.
    31.12.1969 21:00:00 error: destination name 'YoutubeLiberados' not found
    04.02.2020 19:39:02 [sg_create_config] Error Bad config data. It's all error_res: (A5) ACL 'GTI_INFRA' error: destination name 'YoutubeLiberados' not found
    04.02.2020 19:39:02 [sg_remove_unused_db_entries] Removed file '/var/db/squidGuard/YoutubeLiberados'.
    04.02.2020 19:39:02 [squidguard_rebuild_db] Start rebuild DB.
    04.02.2020 19:38:52 [squidguard_rebuild_db] Create rebuild config '/usr/local/etc/squidGuard/squidGuard__usrdbrebuild.conf'.

    error-squidguard.PNG

    Can anyone help me as to why this is happening and how to fix it?
    The squidguard service seems to be running despite this error.

    Thanks a lot!



  • Hey guys, i just solved it entering the ACL where the target category was active and hitting the save button!

    Funny enough, I had hit the general save button on Groups ACL tab, but it seems to have had no effect.

    After I delete a certain target category, is it necessary to enter every single ACL (in the Groups ACL tab) that target category was active and hit save?


Log in to reply