Speed Problem



  • Hallo,

    ich habe hier VDSL50 die bei mir auch voll anliegen.
    Bisher habe ich mit einem Wrap Board und monowall rum gewerkelt und kam damit auf einen max. Speed von ~37Mbit, da das Wrap von der CPU etwas schwach auf der Brust ist.
    Mit pfsense wird es schon gar nichts auf dem Wrap.
    So nun habe ich mal einen alten Standalone PC aufgesetzt, mit 400MHz AMD CPU, 256MB RAM etc.
    Den dann zu Testzwecken mit der LiveCD von pfsense 1.2.3-RC1  gestartet VLAN7 und den ganzen Krempel eingerichtet, den man für VDSL braucht und ich komme damit wie jetzt gerade sogar online.
    Nur ist das Problem wie zuvor mit pfsense und dem Wrap Board, dass ich nur auf einen max. download speed von 13 Mbit komme.
    Beim Wrap war mir das klar, da pfsense etwas systemlastiger ist als monowall stieß es schnell an seine Grenzen mit 100% CPU Last, aber warum nun auch beim alten Standalone PC nur 13 Mbit.
    An einer zu schwachen CPU kann es nicht liegen die ist nur zu 55-60% ausgelastet.

    Egal was ich einstelle, z,B. Use device polling ja oder nein, ich komme nicht über 13 Mbit.
    Die Gegenseite gibt das selbstverständlich her, denn mit monowall und wrap komme ich ja, wie bereits erwähnt auf meine 37 Mbit.

    Was läuft da also falsch, warum kommt pfsense nicht aus 'em Potte.

    Eigentlich wollte ich mit stärkeren Equipment auf pfsense umsteigen, da es mir auf Grund der umfangreicheren Konfigurationsmöglichkeiten besser gefällt, aber was nützen mir die, wenn ich auf keinen ordentlichen Speed komme.



  • Was für NICs verwendest du?
    Gerade bei systemen bei denen die CPU wahrscheinlich an ihre grenzen kommen wird, macht die wahl der Netzwerkkarte EXTREM viel aus.



  • Zwei mit ganz normalen RTL8139 Chipsatz, also Realtek 100 Mbit

    Aber warum an die Grenzen, ich schrieb doch das die CPU mal gerade bei 50-60% rumdödelt.
    monowall habe ich auf diesem Standalone PC noch nicht versucht, aber ich möchte fast wetten, das ich mit der auf 50 Mbit komme.
    Was zieht da bei pfsense also die Bremse?

    Der Standalone ist bis jetzt übrigens nur ein auf dem Schreibtisch liegendes Motherboard mit den entsprechenden Karten drin und 'nem Netzteil daneben  ;D



  • Realtek karten sind notorisch dafür das sie äusserst schlecht sind…
    Ich würde bei dem system intel karten einbauen und mal schauen wies sich dann verhält.



  • So habe mal ein bisschen rum gespielt, unter anderen die beiden unterschiedlichen NICs mal untereinander ausgetauscht, die CPU mal auf 500 MHz übertaktet und nun komm ich mit ach und krach auf 25-30 Mbit.
    CPU dödelt dann bei 60-100% rum, ohne device polling. Mit da sinkt dann zwar die CPU last dafür aber auch der Speed auf 20 Mbit.

    Ich würde bei dem system intel karten einbauen und mal schauen wies sich dann verhält.

    Ja haben und ein Ende weit mit weg sein.
    Eigentlich sollte eh alles nur ein Test werden, um zu sehen auf welchen Speed ich mit einer 500 MHz CPU komme, weil ich mit 'nem neuen ALIX Board liebäugle, welches genau 500 MHz hat.

    Leider habe ich nach diesem Test die Befürchtung das auch das ALIX für VDSL50 und pfsense zu schwach auf der Brust ist  >:(



  • Naja dein problem könnte von verschiedenen dingen beeinflusst werden.
    Wie gesagt: Einer der grössten punkte die netzwerkkarte.
    Wenn du irgend ein problem mit den interrupts hast, kann da auch die performance stark beeinträchtigen.

    Hast du vielleicht noch irgendwelche andere services am laufen ausser basic NATing und routing?

    Vielleicht auch mal noch interessan:
    Wie testest du den speed?
    Downloads/Speedtests im internet?
    Auf das kannst du dich absolut nicht verlassen.
    Die besten resultate erzielst du wohl, wenn du iperf von beiden seiten deiner pfSense einsetzt.

    Das ALIX sollte stark genug sein:
    http://forum.pfsense.org/index.php/topic,12766.0.html

    Conclusions:
    –-------------------
    This setup can do about 85 Mbits/sec clear text throughput...So about a 40 Mbits/sec symmetric link

    älterer test:
    http://forum.pfsense.org/index.php/topic,6911.0.html



  • Nö habe erst mal nur VLAN7 eingerichtet, damit es überhaupt funktioniert, sonst keine weiteren Einstellungen.

    Habe es jetzt mal mit monowall 1.3b16 getestet, damit komm ich auf 43 Mbit, bei ~90-97% CPU Last.

    Einen eigenartigen Unterschied zwischen monowall und pfsense habe ich aber festgestellt, und zwar

    pfsense
    ohne device polling hohe CPU Last 60-100%, speed 25-30 Mbit.
    mit device polling CPU 60%, spedd aber nur 20 Mbit

    monowall
    ohne device polling CPU bei 100%, speed bei 40 Mbit
    mit device polling CPU 90-97%, speed bei 43 Mbit

    Warum fällt bei pfsense mit device polling außer der CPU Last auch der Speed, ist doch sehr eigenartig.

    Zum Test selbst.
    Einmal mit dieser Seite
    http://www.speed.io/index_de.html

    Ist ausnahmsweise mal eine gute, die selber auch genug Speed liefern kann. Man muss immer ein paar Versuche machen, weil es teilweise bis um zu 10 Mbit schwankt.

    Oder Variante zwei ist mit dem Downloadmanager 20 Teile Downloads vom Microsoft ServicePack.
    20 Teiledownloads ist aber Pflicht, da die MS Server ansonsten auch nicht genug liefern.

    Als nächstes werde ich es nun mal mit monowall Version 1.235 versuchen, das basiert noch auf FreeBSD 4.x und ist am Ressourcen schonensten., deswegen läuft es auch auf meinem wrap. Ich kann mir also durchaus vorstellen, dass ich damit auf dem Standalone auf meine 50 Mbit komme.


Log in to reply