"Preserving recently used remote address"



  • I have several sites set up with site to site vpn connections.

    On my router where the connections are terminated, my wan ip changed.

    All the leaf nodes came back up except one.

    I have a client vpn connection to that site, which is on a static static ip, and as I suspected, I had my old ip in the client config, rather than the name which resolves to my ip.

    I entered the fqdn, restarted OpenVPN, and it still tries to connect to the old address.

    I have two external dns servers configured, and I've checked the box on General setup to not use the internal resolver for router dns, and verified that the correct ip is returned by both configured dns servers.

    I'm running 2.4.4
    Client is on 2.4.1

    Is there some switch I can enter in the client config to force it to not use the recent address?

    Or I I missed something blindingly obvious?



  • If the remote endpoint you're connecting to changes its IP-Address on the DNS-name, like in a dyndns scenario, make sure that it is actually changed. DNS has a lot of timeouts that can interfere with that.



  • Found the issue - my own stupidity.

    At some point in the past, I had put my ip in as a host override in the dns server settings.

    Doh!


Log in to reply