HAProxy and Blue Iris web server



  • I tried to set up a Blue Iris web server with HAProxy, but it was not working.
    The Frontend was defined as BI.mywanip.com, the Backend was defined as 192.168.1.202, port 81.
    Blue Iris web was set up as 192.168.1.202, port 81.
    When I entered http://192.168.1.202:81, Blue Iris web server loaded up fine.
    I got an web server not found error when I entered BI.mywanip.com.
    Any one has any idea why? My other web sites in HAProxy were working fine with IIS and apache.



  • @jycai
    If Chrome told you DNS_PROBE_FINISHED_NXDOMAIN then your DNS domain name didn't resolve properly and would have nothing to do with haproxy or webserver. If the webserver did respond that it just didn't serve the requested domain then that would need fixing, perhaps the vhost name isnt configured there?.. Did haproxy stats count the requests? Is it using http mode? Is he server shown as up?



  • @PiBa
    Thank you very much for the reply! I just found out that In order for Blue iris and Calibre to work in Windows, "Health Check Method" need to be set from "HTTP" to "none" in HAProxy Backend.
    🕺

    Do you know why IIS and apache need to be set in "HTTP", but Blue iris and Calibre need to be set in "none"?



  • @jycai
    I'm sure they don't need to be set to 'none'..

    The question is 'why' do those sites not answer with a response that haproxy finds 'valid'.. Do they need a different request, or should haproxy find a different status valid?

    Configure HTTP healthchecks again and look at the stats page. Why does the LastCkh fail?
    https://github.com/PiBa-NL/pfsense-haproxy-package-doc/wiki/haproxy_troubleshooting

    Maybe change the 'method' to GET ?
    Maybe change the requested path / and or http version / accept headers / or does it require a host header to be send?
    Maybe change the expected response code add "http-check expect status 401" in advanced settings of the backend?



  • @PiBa
    GET or HEAD in "Http check method" works!


Log in to reply