LCDproc on Watchguard XTM 5 series with pfSense 2.4.4



  • Has anyone got the LCDproc to work on a Watchguard XTM 5 series with pfSense 2.4.4?



  • Do you mean XTM 5 series? I have a couple of 515's with the LCD working just fine.



  • @chpalmer

    Hi chpalmer

    Same config but no luck.
    Fresh install on XTM 515 - pfsense 2.4.4-RELEASE-p3
    Package lcdproc-0.5.9 successfully installed but the "lcdproc" service does not start.

    When I change the configuration "LCD connection and hardware" the parameters are not saved.

    Your help would be appreciated



  • Version 0.10.6_6 ? I would try uninstalling the package and reinstall.

    You did install from the package manager right?

    LCDproc.jpg



  • @chpalmer

    Yes installed from "package manager" Version 0.10.6_6
    I deleted LCDproc and reinstalled (after a reboot), same result.
    Strangely, when I configure the parameters in the "LCD connection and hardware" screen nothing is saved.

    Will try to reinstall again.
    If you have any suggestion I am listening.

    Thx



  • Ive just installed the LCDproc package on my test box running 2.5 snapshots and everything seems good. It does not actually have any display so I can't see if it is actually working but the boxes populate and stay that way after hitting the save button.

    Im curious if you are using an SD card as your drive media? Mine are all HD units.



  • @chpalmer Of course its the XTM 5 series. Sorry about that :)



  • Exactly the same problem as @decm

    0f00e3d9-e510-4b04-996c-ba99b1c61295-image.png

    When I save and going back to options it's back to default.
    And when I try to start the service from dashboard it's going back to stopped state.

    77e80a8a-48f3-4d33-ad7a-84dd5222bdb1-image.png



  • @chpalmer said in LCDproc on Watchguard XTM 5 series with pfSense 2.4.4:

    Im curious if you are using an SD card as your drive media?

    ?? Either of you guys?



  • I use a 240GB SSD as storage.



  • @chpalmer

    I installed from a CF card to a 120 GB HD. With all the problems encountered, I decided to install 2.5 and it was successfully and LCDproc was operational as expected. So I reinstalled 2.4.4-p3 and added LCDproc and now everything is normal. I don't know what happened but everything is fine.

    Thanks again for your support. It was a pleasure to chat with you.

    Mike



  • Truthfully you guys have me leery about touching my primary box here.. Its on 2.4. snaps . But since it wont affect actual operations I might just try to modify settings and see if they take..

    glad ya got yours working decm!

    mtnhansen- can you take a peek at your config file and see if it looks correct? You should find at 6 instances in your config file looking like below.

    <menu>
    <name>LCDproc</name>
    <tooltiptext>Set LCDproc settings such as display driver and COM port.</tooltiptext>
    <section>Services</section>
    <url>/packages/lcdproc/lcdproc.php</url>
    </menu>

    <service>
    <name>lcdproc</name>
    <rcfile>lcdproc.sh</rcfile>
    <executable>LCDd</executable>
    <description><![CDATA[LCD Driver]]></description>
    </service>

    <lcdproc>
    <config>
    <enable>yes</enable>
    <comport>lpt1</comport>
    <size>20x2</size>
    <driver>sdeclcd</driver>
    <connection_type>lcd2usb</connection_type>
    <refresh_frequency>5</refresh_frequency>
    <port_speed>0</port_speed>
    <brightness>-1</brightness>
    <offbrightness>-1</offbrightness>
    <contrast>-1</contrast>
    <backlight>default</backlight>
    <outputleds>yes</outputleds>
    </config>
    </lcdproc>

    <lcdprocscreens>
    <config>
    <scr_version>yes</scr_version>
    <scr_time>yes</scr_time>
    <scr_uptime>yes</scr_uptime>
    <scr_hostname>yes</scr_hostname>
    <scr_system></scr_system>
    <scr_disk></scr_disk>
    <scr_load></scr_load>
    <scr_states></scr_states>
    <scr_carp></scr_carp>
    <scr_ipsec></scr_ipsec>
    <scr_slbd></scr_slbd>
    <scr_interfaces></scr_interfaces>
    <scr_mbuf></scr_mbuf>
    <scr_cpufrequency></scr_cpufrequency>
    <scr_traffic></scr_traffic>
    <scr_traffic_interface>lan</scr_traffic_interface>
    <scr_top_interfaces_by_bps></scr_top_interfaces_by_bps>
    <scr_top_interfaces_by_total_bytes></scr_top_interfaces_by_total_bytes>
    <scr_top_interfaces_by_bytes_today></scr_top_interfaces_by_bytes_today>
    <scr_traffic_by_address></scr_traffic_by_address>
    <scr_traffic_by_address_if>wan</scr_traffic_by_address_if>
    <scr_traffic_by_address_sort>in</scr_traffic_by_address_sort>
    <scr_traffic_by_address_filter>local</scr_traffic_by_address_filter>
    <scr_traffic_by_address_hostipformat>descr</scr_traffic_by_address_hostipformat>
    </config>
    </lcdprocscreens>

    <package>
    <name>LCDproc</name>
    <descr><![CDATA[LCD display driver.]]></descr>
    <version>0.10.6_6</version>
    <configurationfile>lcdproc.xml</configurationfile>
    <include_file>/usr/local/pkg/lcdproc.inc</include_file>
    </package>

    Last one is a menu item and not copied here..



  • @chpalmer Everything looks right, but I'm missing what is in the ldcproc config area.



  • Are you running any other packages? Do they update ok?

    You could take my data above and infuse it into your config and then reload it. But that doesn't solve the issue as to why you are having this problem.



  • @chpalmer Yes, other packages are running and they are updated without problems



  • @chpalmer I copied parts of config you posted and now its working! Thank you!
    08cb0960-7d45-4a2d-8bbb-c17d2f71cbe9-image.png

    9dd035b3-3491-4633-a4ac-72e546942903-image.png



  • As someone who is also having this issue I just wanted to add that it has to do with LCDProc assuming that the parallel port is not valid. If you go into the logs you should see this line "lcdproc: The selected COM port is not valid!” I am still working on why this is the case

    I tried editing the LCDproc.xml file with the settings above and still no luck. Driving me crazy because this use to work



  • If your setup is not seeing the parallel port then either it has gone bad or you need to turn it on in BIOS.. or the LCD unit has gone bad. Try plugging the cables in and out a couple of times.

    These are older systems now. Mine was a year old (display model) when I got it and Ive been using it 5 years.



  • @chpalmer Mine LCD is working as it displays ‘pfSense V1.8’ (even though I am running 2.4.4) and parallel port shows up. I am having the same issue as OP whereas none of the settings get saved. Even if I set COM port to ’none’ I get 'lcdproc: The selected COM port is not valid!'

    Would you mind letting me know the location of the .xml config you shared? I just want to make sure that it is in the right place.

    Edit: I have uninstalled, cleaned up files that it would not remove like lcdproc.xml as I edited it. Rebooted the firewall. Reinstalled, still same issues. I wonder if it is because I am on the latest version of LCDproc and you guys seem to be on a slightly older one? The first time I set this up it worked without hiccups. HDD died so I reinstalled pfSense and ever since then LCDproc has not worked.



  • @ablizno

    That is from the standard config. You don't want to remove it. You will kill your firewall.

    Im on the latest as well. And when I installed on my 2.5 test box everything worked as well. Im reluctant to uninstall and reinstall on my primary box now as I might run into the same issue.



  • @chpalmer Ah okay I assumed it was the lcdproc.xml file. I cant find most of what you posted in /conf/config.xml I’ll tinker with it and see if I can get it working without breaking anything.



  • Its the main pfsense config file. Go to /Diagnostics/Backup and Restore.



  • So the issue has to do with the config file not getting updated during the initial setup. I added the lcdproc tags and also fixed my issue.


Log in to reply