Total Newb - Help Request - Slow OpenVPN



  • Got Pfsense up and running in a test lab.
    My network (live) is 172.18.18.0/16
    My test network (behind the pfsense) is 172.25.21.0/16
    OpenVpn Tunnel is 192.168.7.0/24
    I have AES-NI active on Pfsense.

    So a couple of things that I can't figure out.

    1. I can't access the Lab network from the live network. Although I have entered 172.25.21.0/16 as the remote network, I can't ping, RDP.....see anything. The only way to resolve this is to use the Force all traffic option. As such, I put this as my first issue as I must have something set wrong.

    2. pulling a file from the live network to the lab (not using openvpn), I can pull at 100+ MBps (gigabit network). However, as soon as I go to OpenVPN, I am at 2-3 MBps.

    I know this can work but I am at a loss as to what to change or look at.
    I have tried to use push "Route 172.25.21.0 255.255.0.0", and that does not work.
    I have tried numerous options in the OpenVPN settings and just can't get it to go.

    This is going to be used for site to site and clients to site in that both sites will have gigabit fibre lines for their internet connection.

    Can anyone offer some advice.


Log in to reply