Squid Proxy through VPN Tunnel


  • I've looked through the forum here and haven't found a simple / working solution.

    I run an always on VPN using OpenVPN which generally has a 0% packet loss. I would like to setup squid caching as my bandwidth is limited. However when I turn on Squid my loss on the Gateway interface (my OpenVPN) goes to around 20-50 packet loss and the tunnel eventually drops and rebuild. This then creates a loop and I need to stop the Squid service to get everything back to normal.

    Is there a way to specify how to get the Squid service to use the default interface? I have my wan interface setup as a VPN group and I would like all traffic even internal traffic to go through it. I already tag all traffic from the LAN interface and then I have a floating rule to block the traffic if there is no VPN tunnel up.

    Thanks.


  • I ran across this in my recent searches as an option but the cron script that they have only works for one ovpnc1 interface. This wouldn't work because I use a Gateway Group that is both ovpnc1 and ovpnc3.

    Is it possible to create a floating rule that says anything going out of WAN on port 80 (assuming only http transparent proxy) from "This Firewall (self)" gets passed to a gateway group?