• I'm not new to VLANs, I have them set up on other equipment but I cannot for the life of me get it working with pfsense.

    I have followed many tutorials to no avail.

    What I have done:

    interface -> VLANs -> added a vlan configuration under the parent lan (lagg0) vlan tag 20

    interfaces -> select vlan20 from available ports and clicked add.

    interfaces -> opt1 (the new iterface for vlan20) -> IPv4 static, IPv4 address 10.10.20.1/24

    interfaces -> switches -> VLANs -> added a vlan 20 to port 3

    services -> DHCP server -> OPT1->enable DHCP server on LAN interface, ip range 10.10.20.100 - 10.10.20.200

    firewall -> rules-> created an allow all rule under opt1

    I have a TP-Link switch set up from another vlan that was set up the same way and was working on that network (even tried to reconfigure it) but does not work

    I took a computer and connected it directly to port 3 and set up a vlan id on the NIC to 20 and it still fails to get an IP.

    pfsense can ping if i set static IPs and nmap can see things on that vlan if they are configured with static IPs but there is still no internet and no DHCP.

    Is there something I am missing?


  • the logs also show dhcp discover and offer (on the correct vlan) but then loops over again and again - it never gets the request or ack.