Rule loading error, no IP address found



  • Suddenly I'm getting this error

    "There were error(s) loading the rules: no IP address found for 2804:689a - The line in question reads [689]"

    My router is now unusable. What can I do, short of nuking the configuration? I don't know how to find out what is causing this. I've tried disabling every IPv6 rule and everything IPv6 related.

    I'm running 2.3.5p2 embedded.


  • LAYER 8

    i don't think that someone is able to help you on that, 2.3.5-p2 is eol
    the only suggestion i can give you is to upgrade to 2.4.4-p3 asap



  • Would if I could, but my router is 32-bit, so I can't have 2.4.x.



  • If you did not change anything Id be surprised if you were not seeing an impending hardware failure on your drive media there.

    I assume this happens when you boot up? your description is lacking a bit in information. :)



  • @chpalmer I have been changing things, I just can't pin-point what exactly I was doing right before this error started occuring. Now it does appear on every rule load, so at boot too.

    Actually according to logs, it appears that the file system had become full some time before this error first occured. Now I have freed up plenty of space, but can't get rid of the error.



  • @kurppa said in Rule loading error, no IP address found:

    2804:689a

    Can you see anything related to this error on the console port? Have you tried changing the IP address there?



  • It was the bogonsv6 table that was messed up. After I removed the block private & bogons options from the WAN interface, the error disappeared. Then off to launch the table update manually. An interesting thing is that as soon as I reapplied the block bogons option, the router spontaneously rebooted 🤔
    Everything appears to be working fine after the reboot.



  • @kurppa Awesome!


Log in to reply