Captive portal image problem again

  • Hi all

    I've uploaded an image using the captive portal upload file manager (herotell.png) and uploaded a portal.html page with the following html code (captiveportal-) prepended


      <span> <i> Internet link sponsored by </i> </span>
      <img style="width:200px;" src="captiveportal-herotell.png"/><br>

    But it refused to show this image

    I checked the firewall /usr/local/captiveportal: directory - looks like file is there

    2.4.4-RELEASE][admin@iNethiMonitorOV.localdomain]/usr/local/captiveportal: ls -al
    total 104
    drwxr-xr-x 2 root wheel 512 Mar 4 15:40 .
    drwxr-xr-x 17 root wheel 512 Feb 2 2019 ..
    -rw-r--r-- 1 root wheel 82730 Sep 5 2018 captiveportal-default-logo.png
    lrwxr-xr-x 1 root wheel 45 Mar 4 15:39 captiveportal-herotell.png -> /var/db/cpelements/captiveportal-herotell.png
    lrwxr-xr-x 1 root wheel 41 Mar 4 15:40 captiveportal-logo.png -> /var/db/cpelements/captiveportal-logo.png
    -rw-r--r-- 1 root wheel 9301 Sep 5 2018 index.php

    Strange thing is that the other graphic element (captiveportal-logo.png) does display snipped of html earlier in the portal.html file for that is

    <div id="content">
    <div class="login-card">
    <img src="captiveportal-logo.png"/><br>
    <button class="button" onclick="window.location.href = '';">Click here to </button>


    Am I missing something - I've restarted the firewall, captive portal ... tried everything

  • When you use your browser to inspect the login page, check the img source link.
    If the image doesn't show, it will show why.

    From memory, if your set Status > System> Logs > Settings > Web Server Log // Log errors from the web server process, you will be able to see the reason why the web server nginx can't show the page.

    Also : if you use the $$$$$ browser, use another one, or really empty the cache.

    Check also if the files really exists here : /var/db/cpelements/......

  • Oops sorry about the false alarm - it turned out being a browser cache issue .. amateur hour :)

Log in to reply