SolarFlare SFN5122F



  • Hello,

    I've got a SolarFlare SFN5122F that I want to use for my LAN connection. When I connect it to my switch I get link lights on both the switch and the NIC until pfSense brings up my LAN connection. I have gotten it to link up as an OPT interface if I set it up and assign a random IP to it while continuing to use one of my Intel NICs as my LAN NIC.

    Tonight I will be checking logs & dmesg output, but any other suggestions are welcome. I did add sfxge_load="YES" to /boot/loader.conf and I can see the interfaces on the card in the GUI, just can't use it as my LAN yet....

    Forgot to mention, I am on 2.4.4-p3 right now.


  • Netgate Administrator

    I've only once seen anyone using that driver with any NIC and in that case it would link but not pass traffic. They were also trying to use it in a lagg though.

    Get the output of ifconfig -vvma both with and without the NIC connected. Make sure it's showing the correct link speed etc.

    Make sure your LAN settings are not trying to configure the NIC to some rate it cannot use for example. There must be something different it is doing compared to OPT.

    Steve



  • I will do that tonight, although I'll have to take screenshots.


  • Netgate Administrator

    Also you should put that loader variable in /boot/loader.conf.local to avoid it being overwritten at some point. Create that file.



  • @stephenw10 Are you talking about sxfge_load? It is in /boot/loader.conf

    Additionally, before I forget. ifconfig sfxge0 shows no carrier when it is set as my LAN connection.


  • Netgate Administrator

    Yes it should be in loader.conf.local.
    loader.conf can be overwritten at upgrade etc so if you leave it there it might disappear at some point leaving you with no interface.
    About the only thing I could imagine cause no carrier would be a speed/duplex setting in the LAN config.

    Steve



  • @stephenw10 Yeah, not sure how to change the speed and duplex from auto to 1GFD without access to the web GUI. And when I had the OPT interface up and running it was set to auto as well.


  • Netgate Administrator

    A lot of 10G cards do require setting to 1G to link at that but otherwise should be left as auto.

    Was it linking at 10G when you had it as OPT?

    I would make sure you have access via some other interface before doing any of this. That could be via the WAN even if only temporarily.

    Steve



  • It was linking at 1G, but that was expected. I don't have a 10G switch yet. Assigning the SolarFlare card from the console when I still have my current Intel card in to handle VLANs should let me connect via a VM on a VLAN, right?


  • Netgate Administrator

    Hard to answer that question without knowing exactly how you network and VMs are setup exactly. 😉

    But, in general, yes leave the Intel card in and assigned so you have access to the webgui and then configure the solarflare card separately. The Intel card will not be re-assigned, VLAN interfaces will not be moved simply by assigning another NIC.

    Steve



  • @stephenw10 I was planning on re-assigning my LAN interface to the SolarFlare NIC and leaving the VLANs on the Intel NIC. My VMs are on their own VLAN so I should be able to access one of them via RDP, and from there access the pfSense box.


  • Netgate Administrator

    Yes you should. VLANs are assigned as a different interface so if you have, for example, igb0.100 assigned as OPT2 then reassigning LAN, even if that was igb0, will not affect it. As long as the interface remains physically connected to the link carrying the VLAN.

    Steve



  • @stephenw10 You were right, I did have to force it to a 1000baseSX <full-duplex,rxpause,txpause> connection. Still trying to get IPv6 track interface to work on it though.


  • Netgate Administrator

    Hmm, I wouldn't expect that to be affected by the NIC/driver. Unless maybe it has some odd MAC that local-link objects to. Or maybe some hardware off-loading option?

    Steve



  • @stephenw10 I just had to reboot the router for it pickup the IPv6 addresses on the other interfaces. I was hoping to avoid that but I guess not.



  • Just added sfxge_load="YES" to /boot/loader.conf.local because I forgot to last night.....


Log in to reply