OpenVPN Routes to Remote sites



  • I'm looking from some guidance to resolve what I believe is most like something to do with static routes. I have a number of users who are connecting to our Home Office via OpenVPN. They can access any resource at the Home Office, but are unable to access anything at the remote site that are connected to the Home Office via Site to Site VPNs.

    Home Office
    WAN: 134.XXX.XXX.XXX
    LAN: 192.168.10.0/24
    OpenVPN: 172.16.10.0/24

    Site 2
    WAN: 135.XXX.XXX.XXX
    LAN: 192.168.2.0/24

    Site 3
    WAN: 12.XXX.XXX.XXX
    LAN: 192.168.3.0/24



  • Got to the remote access server settings and add all LANs to the "IPv4 Local Network/s", comma seperated, if you don't have "Redirect gateway" checked. With "redirect gateway" there is nothing to do here.

    On sites 2 and 3 add 172.16.10.0/24 (access server tunnel network) to "IPv4 Remote Network/s".



  • @viragomann said in OpenVPN Routes to Remote sites:

    172.16.10.0/24

    I'm not following where to do the second part of your instructions. The sites are connected using IPsec Site to Site VPN tunnels if that makes any difference.

    Thank you for your help with this!



  • @heathstiles said in OpenVPN Routes to Remote sites:

    The sites are connected using IPsec Site to Site VPN tunnels if that makes any difference.

    You didn't mention above. Of course is that different.

    So will have to add an additional phase 2 in the IPSec configuration for the respective local network and the OpenVPN tunnel network.


Log in to reply