Orario server openvnp diverso da orario pfsense



  • Salve a tutti, ho attivato openvpn su pfsense ma quando un utente si collega come orario ne da uno diverso rispetto a quello dell'ente


  • LAYER 8

    non mi è chiaro
    puoi elaborare meglio il problema?
    hai configurato il server ntp su pfsense ? ma esattamente cosa succede?



  • praticamente l'orario di pfsense è corretto mentre l'orario di connessione degli utenti in vpn è come se fosse tre ore più avanti


  • LAYER 8

    controlla che su
    System / General Setup
    sia impostato timezone su europa/rome



  • allego uno screenImmagine.png


  • LAYER 8

    potrebbe esserci stato un aggiornamento dell'orologio dopo aver effettuato la connessione vpn?
    non trovo nessun altro con questo problema, e non ci sono bug aperti in merito, il mio mostra l'orario giusto, hai provato magari a riavviare e a vedere se il problema persiste?

    Per quanto riguarda gli indirizzi ip che mi chiedevi, che configurazione ti hanno dato ? il classico con subnet 255.255.255.248 ?



  • si, una barra /29.
    Per l'orologio si prende sempre ora corrente + 2:20 circa


  • LAYER 8

    per gli ip ti ho risposto nell'altro thread, per l'orologio sto chiedendo se qualcuno sa qualcosa, appena mi rispondono ti faccio sapere


  • LAYER 8

    per l'orologio ho trovato in giro che potrebbe essere un settaggio errato nell'orologio del bios, tipo ora solare / ora legale utc settato male dove però il sistema operativo riesce a calcolare l'orario giusto mentre openvpn no



  • grazie provo a fare un date sulla macchina virtuale


  • LAYER 8

    sorry to bother you @jimp, i'm pretty mutch alone on this section of the forum, but by chance can you give us indications/suggestion on why the openvpn time is 2 hours ahead of the system time? even after a reboot and even after a restart of openvpn
    it's a virtual machine under esxi
    tnx


  • Rebel Alliance Developer Netgate

    I have not seen that happen before, so I'm not sure what it might be. Usually a reboot after setting the time zone clears anything like that up. Maybe a slight chance it might be weird if the BIOS clock is set to UTC instead of local time. That should work but it's not something we see a lot of.


  • LAYER 8

    ok @Lorebo anche secondo lui che è uno degli sviluppatori deve esserci qualcosa nel bios o in esxi che gli passa l'orario utc sbagliato alla tua macchina virtuale, secondo me il sistema operativo pfsense/freebsd riesce a compensare mentre openvpn non ci riesce e legge l'ora sbagliata


Log in to reply