pfS openvpn client -> vserver openvpn server



  • Hallo zusammen,

    ich schlage mich schon seit Tagen mit dem openvpn client herum und kann es einfach nicht herausfinden, warum er sich nicht verbinden will.

    Mein Setup:

    Ich habe alle Einstellungen aus der ovpn Datei so gut es ging ins GUI der pfSense übertragen und habe auch genau auf die Cipher geachtet.

    Bekomme aber nur nichts aussagende Meldungen.
    openvpn client log: https://pastebin.com/pzweH1qf
    openvpn server conf: https://pastebin.com/yDw6tzXM
    openvpn client conf: https://pastebin.com/uXCTgZVw
    screenshots von gui: https://imgur.com/a/7FrYtxx

    Ich wäre euch sehr dankbar bei Hilfe des Problems.

    Gruß Daniel



  • Hi,
    zunächst gehören die Bilder hier ins Forum.
    Dann würde ich den Port 443 auf einen normalerweise nicht genutzten Port ändern. Wenn hier wider Erwarten etwas lauscht, dann dringt der Ruf nicht zum OpenVPN durch. Dann weiterschauen
    Gruß



  • @pfadmin said in pfS openvpn client -> vserver openvpn server:

    Hi,
    zunächst gehören die Bilder hier ins Forum.
    Dann würde ich den Port 443 auf einen normalerweise nicht genutzten Port ändern. Wenn hier wider Erwarten etwas lauscht, dann dringt der Ruf nicht zum OpenVPN durch. Dann weiterschauen
    Gruß

    Hi, vielen dank für deine Antwort. Auf dem openvpn server laufen 100% keine andere dienste. Das Profil funktioniert auf Windows/Linux&Android.
    Bzgl. der Bild sry wusste mir nicht anders zu helfen.

    Gruß



  • (Protokoll sollte udp sein, nicht tcp) Willst du Peer to Peer machen, oder doch Client-Server?
    Es sieht aber eben so aus, als ob genau nach dem Zugriff auf Port 443 die Verbindung resettet wird. Nimm einfach einen anderen Port, dann ist die Fehlerquelle erstmal ausgeschlossen.


  • LAYER 8 Moderator

    Die custom options sind IMHO unnötig und werden automatisch gesetzt. Würde ich ggf. nachsehen im erzeugten Konfig-File. Man muss nicht jeden Krempel übernehmen auf Teufel komm raus ;)

    Das Log vom Client (erster Pastebin?) sieht typisch dafür aus, dass nichts ankommt. Versucht die Verbindung zu 123...:443 und bekommt ein TCP Reset weil nichts zurückkommt. Verstehe zwar nicht warum da mit Brechstange versucht wird 443/tcp zu nutzen, aber da würde ich den Server checken und ggf. Firewall, IPtables o.ä. prüfen -> da scheint nichts anzukommen. TCPdump hilft.


Log in to reply