Airplay not working - inter VLAN



  • Hi all,

    this is most likely not a pfSense issue, but there's a lot of expertise here, I hope one of you can point me in the right direction.

    Network setup:
    ISP - Bridged modem - PfSense - Cisco SG250 switch - Netgear GS108Ev3 switch - Netgear GS105Ev2 switch - Receveiver
    The Cisco is also connected with an Unifi AP.

    Pfsense version 2.4.4-RELEASE-p3

    IGMP snooping is disabled on all switches.
    The receiver and client are in the same VLAN, and I can access the webinterface of the receiver, but the client (iPhone) does not find the reciever through airplay. It used to work before I installed the Cisco and created the VLANs.

    Since it's all inter-VLAN and same subnet I assume firewall rules are not relevant to post?
    Avahi is enabled, but again, inter VLAN so not relevant?

    I could not find anything in the logs...

    Like in my other post I have no idea how to troubleshoot, and would be grateful for any help!



  • Hi,

    @jeecee said in Airplay not working - inter VLAN:

    The receiver and client are in the same VLAN

    Just to be sure :
    When you put that client and receiver together on a dumb switch, this switch hooked up to pfSense directly, it works ?

    I do not use VLAN (NIC are so not-expensive these days, far less as manageable switches) but I'm pretty sur that all devices on the same VLAN network is like all devices on the same LAN (network).

    pfSense does not interact with devices on the same network : they can reach each other just fine by yelling around = broadcasting etc, on their network.

    Install this app : Discovery.

    3bfc8fea-029b-4ff2-9091-9aaf244c7c9a-image.png

    It's shows everything with details.
    There are zero configuration options and one rule : you have to use a Wifi connection.

    a155c46e-4edd-438b-8ad3-2424e956054c-image.png


Log in to reply