Snort Package v3.2.9.10_2 Release Notes



  • Snort v3.2.9.10_2

    WARNING!!! Do not install this new version on a pfSense-2.4.4 box! You will get a missing dependent library error for libpcap and Snort will fail to start.

    An update for the Snort package is posted. This updates the Snort GUI package on pfSense-2.4.5 RELEASE to support the latest 2.9.15.1 Snort binary. Two new features are added to the GUI and one reported bug is corrected. This package version is for pfSense-2.4.5 only!

    Installation Notes: if you are running pfSense-2.4.4, first update to pfSense-2.4.5 before attempting to update the Snort package! Once pfSense-2.4.5 is up and running, you may update the Snort package.

    New Features:

    1. Filter Panel parameters, when filtering is enabled on the ALERTS tab, are now persistent across page submits so that previously defined filtering parameters do not reset when submitting a revised filter.

    2. A new "Exact Match" option was also added to the Filter Panel. When checked, this causes matches only when each provided filter parameter matches exactly. When unchecked, filter values will match on partial strings.

    Bug Fixes:

    1. On IP REP tab, the file browser icons are broken due to an incorrect image source file path.


  • Possibly, there is a bug in the actual release preventing the executable to be started because of a missing library dependency - could you please take a look into it?
    https://forum.netgate.com/topic/151676/snort-package-version-3-2-9-10_2-shared-object-libibverbs-so-1-not-found-required-by-libpcap-so-1



  • With the upgrade to pfSense 2.4.5 the issue is resolved.



  • @brma said in Snort Package v3.2.9.10_2 Release Notes:

    With the upgrade to pfSense 2.4.5 the issue is resolved.

    Thanks for the update. I was about to test upgrading a 2.4.4 test VM I have. I could reproduce the error in the VM initially. It's an issue caused by the libpcap dependency Snort has. Apparently a little different version of that library exists in pfSense-2.4.4.

    Oh well, everyone needs to update to 2.4.5 anyway ... ☺.



  • True! ☺
    Anyhow: THANK YOU for the fast response!



  • @brma said in Snort Package v3.2.9.10_2 Release Notes:

    True! ☺
    Anyhow: THANK YOU for the fast response!

    Added some additional warning text to the Release Notes post and provided instructions to update to 2.4.5 before applying this Snort update.


Log in to reply