FRR 0.6.4_3 not installing on 2.4.4-RELEASE-p3 (while FRR 0.6.4_2 works)



  • I'm migrating all my servers to use FRR for dynamic routing. Half my servers I upgraded yesterday, where I was successfully able to install FRR 0.6.4_2.

    Today when I try to install FRR 0.6.4_3, I'm not able to, due to package conflicts. This has effectively left me stranded, with FRR half-deployed. HELP! :)

    >>> Installing pfSense-pkg-frr... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up to date.
    Updating pfSense repository catalogue...
    pfSense repository is up to date.
    All repositories are up to date.
    Checking integrity... done (1 conflicting)
      - py37-setuptools-41.4.0_1 [pfSense] conflicts with py27-setuptools-39.2.0 [installed] on /usr/local/bin/easy_install
    Checking integrity... done (0 conflicting)
    The following 16 package(s) will be affected (of 0 checked):
    
    Installed packages to be REMOVED:
    	pfSense-2.4.4_3
    	bind-tools-9.12.2P1
    
    New packages to be INSTALLED:
    	pfSense-pkg-frr: 0.6.4_3 [pfSense]
    	frr7: 7.2_1 [pfSense]
    	libssh: 0.9.3 [pfSense]
    	libyang: 1.0 [pfSense]
    	rtrlib: 0.6.3 [pfSense]
    
    Installed packages to be UPGRADED:
    	python27: 2.7.16 -> 2.7.17_1 [pfSense]
    	readline: 7.0.3_1 -> 8.0.1 [pfSense]
    	krb5: 1.16.1_5 -> 1.17.1 [pfSense]
    	clamav: 0.101.2,1 -> 0.102.2,1 [pfSense]
    	json-c: 0.13 -> 0.13.1_1 [pfSense]
    	sqlite3: 3.28.0 -> 3.30.1 [pfSense]
    	php72-readline: 7.2.10 -> 7.2.29 [pfSense]
    	wpa_supplicant: 2.8 -> 2.9 [pfSense]
    	ipmitool: 1.8.18_1 -> 1.8.18_2 [pfSense]
    
    Number of packages to be removed: 2
    Number of packages to be installed: 5
    Number of packages to be upgraded: 9
    
    The operation will free 25 MiB.
    pkg-static: Cannot delete vital package: pfSense!
    pkg-static: If you are sure you want to remove pfSense, 
    pkg-static: unset the 'vital' flag with: pkg set -v 0 pfSense
    Failed
    
    

    While this gets fixed, in the interim, is there a way (perhaps via the command line), where I can install FRR 0.6.4_2?

    Please help, anyone. My network is half deployed and I have no clue what to do.

    Thanks.



  • Ah, I see a PfSense 2.4.5 has just come out and maybe that's what's going on. I'll try an OS update first.



  • Yep, it installs successfully on PfSense 2.4.5-RELEASE. Would be nice if the package manager indicates OS version compatibility.



  • I am having exactly the same issue. However don't wish to upgrade to 2.4.5 as I am having a few issues with that. Is there a command you can run to install FRR 0.6.4_2 manually ?


  • Rebel Alliance Developer Netgate

    @smaxwell2 said in FRR 0.6.4_3 not installing on 2.4.4-RELEASE-p3 (while FRR 0.6.4_2 works):

    I am having exactly the same issue. However don't wish to upgrade to 2.4.5 as I am having a few issues with that. Is there a command you can run to install FRR 0.6.4_2 manually ?

    No. Since 2.4.5 is out, there is no way to keep the packages pointed at the old 2.4.4 repository. You have to upgrade to access any packages.


Log in to reply