Enable Captive portal



  • Hi, I'm starting to use pfsense and and I think it's very very… good, excellent.

    I have rc1 already working just for a firewall to access the internet with Lan and wan and it works fine.
    Now I'm trying to enable captive portal. I think everything is well configured but the problem is that in the client lan I can browse the internet without any authentication.
    Maybe something is missing in the configuration that I'm not awared off. ???

    1. Configuration FW(LAN)
    lan net -> any -> any  -> gateway (allow)

    2. Configuration CP
    Enable on LAN
    logout popup
    Local User manager
    portal page configured
    error page configured

    Thank you in advance



  • I didn't have any answer. Is it necessary more information to make my problem more clear?
    Tks



  • Try rebooting after enabling captive portal.



  • Hi sullrich,

    I already tryied and now once again but unfortunatly didn't work out.
    Then I disabled it, reboot, reconfigured it again reboot and still not working.
    Don't know what more to do



  • Please make sure you run one of the latest snapshots : http://pfsense.com/~sullrich/RELENG_1_SNAPSHOT-07-12-2006/



  • Captive portal work fine at my work.  You must be doing something wrong.

    It's been brought up here many times, please search the forum and try the suggestions provided to others.



  • Hi,

    I'm testing the snapshot 07-12-2006 as you suggested.
    Now with the same configuration and when I enable the CP in the LAN it blocks all the traffic LAn -> WAN without leaving any logs. I have "Log packets blocked by the default rule" enabled.
    When I disable CP immediately I have access to Internet.
    I'm reviewing all the configs.

    Thanks again



  • Make sure DNS on the client is pointiing to the firewall itself.



  • Hi,

    yes, gateway, and dns are pointing to the firewall.


Locked