Forzare l'uscita sul gateway 2 (WAN2) per un solo IP della Lan.



  • Ciao a tutti. Ho installato la 1.2.3 RC1 da qualche giorno e la sto facendo girare in produzione. Diciamo che mi fido in quanto, in caso di problemi, spengo la macchina, cambio hard disk e in 2 minuti ho su il "vecchio" firewall IPCOP perfettamente funzionante da ormai qualche anno.
    Sto testando le varie features con i piedi di piombo e mi sto scontrando con questo problema:
    ho 2 adsl entrambe con IP statico (WAN1 e WAN2). Tutto configurato correttamente.
    Ho creato una regola nella LAN del firewall secondo la quale SOLO il mio IP esce usando la WAN2 e si trova sopra la regola secondo la quale tutta la rete interna esce usando il default gateway che è la linea WAN. Al momento non ho creato nessun pool per il load balancing o il failover.
    Dopo aver verificato che effettivamente solo la mia macchina usciva tramite wan2 (ho fatto un whatismyip.com e l'IP pubblico è proprio quello della WAN2), ho creato un alias comprendente una serie di indirizzi della LAN (compreso il mio) ed ho poi modificato la mia regola cambiando alla source il mio IP con l'alias.
    A questo punto non c'è stato più verso di far usare la wan2 a Pfsense. Tutta la LAN esce con il gateway della WAN ?!?!?!?
    Potrà sembrare un test senza senso ma voglio capire bene come funziona il software prima di addentrarmi in configurazioni + complesse.
    Grazie a chiunque vorrà fornirmi delucidazioni
    Buona giornata
    MAx



  • Hai configurato l'advanced nat in modo corretto per far "nattare" l'ip in modo corretto ?

    Ciaoz.- Ma.S.Caos.-



  • @Ma.S.Caos.-:

    Hai configurato l'advanced nat in modo corretto per far "nattare" l'ip in modo corretto ?

    Ciaoz.- Ma.S.Caos.-

    Mi spieghi meglio cosa intendi? Sono andato alla voce NAT scheda Outbound e vedo selezionato automatic outbound NAT. Devo selezionare Advanced Outbound NAT ?
    Grazie mille
    Max



  • @MaxFontana:

    @Ma.S.Caos.-:

    Hai configurato l'advanced nat in modo corretto per far "nattare" l'ip in modo corretto ?

    Ciaoz.- Ma.S.Caos.-

    Mi spieghi meglio cosa intendi? Sono andato alla voce NAT scheda Outbound e vedo selezionato automatic outbound NAT. Devo selezionare Advanced Outbound NAT ?
    Grazie mille
    Max

    Esatto … pf automaticamente ti crea la nat per fa uscire la lan tramite la wan ... qualcosa del tipo

    Interface  Source  Source Port  Destination  Destination Port  NAT Address  NAT Port  Static Port  Description
    WAN          192.x.x.x/24  *                          *                      *                    interface (o ip)  *            *                    Automatic

    tu devi agg. qualcosa del tipo
    Interface  Source  Source Port  Destination  Destination Port  NAT Address  NAT Port  Static Port  Description
    WAN2        IP II rete      *                          *                      *                    interface (o ip)  *            *                    Automatic

    Ciaoz.-



  • Esatto … pf automaticamente ti crea la nat per fa uscire la lan tramite la wan ... qualcosa del tipo

    Grazie ! A forza di smanettare c'ero arrivato ma ancora non funzionava! Poi mi è venuto in mente che nel frattempo ho installato squid.
    e abilitato la modalità trasparente ( ho bisogno di avere i log della navigazione). Ho arrestato quindi squid ed ora tutto funziona!
    Riesco a "pilotare" le uscite di alcuni IP verso il gw che voglio e contemporaneamente lasciare abilitato squid?
    Grazie ancora!
    Ciao
    Max



  • Mi spiace ma con squid mi cogli in fallo … ho fatto molti esp. ma non sono mai stato soddisfatto a pideno di squid (con pf intendiamoci) ... ho lo stò provando con pf2 ed è tutta un altra storia ... sono certo però che con la modalità trasparente abilitata ci siano delle limitazioni aggirabili solo con delle ben determinate regole di firewall e nat reflection ... un lessi un post ... ma non mi ricordo se qui in ita o nel generale.

    Ciaoz.-


Locked