openVPN issue : remote client partially loses internet connexion


  • Hi,
    I've made a pretty simple openVPN setup to allow remote users to connect to our school LAN network.
    I've let nearly everything default, just created the users and certificates necessary, using 10.0.9.0/24 as TUN IPv4 network, I also provided domain name and dns on our LAN and local IPv4 network (but that option doesn't seem to do anything actually since I can connect to all remote LAN systems whether it is set or not).

    Everything works as expected, the tunnel setup is very fast. I am using a linux Mint client but same with windows clients :

    issue : when connected to the school LAN through the vpn, my client computer cannot browse internet anymore, BUT not entirely : I'm still able to Google anything and I'm getting the answer. But cannot open any of them. Also, the sites I was connected to before opening the vpn connection seem to still be reachable, altough I didn't invetigate much.

    I feel a bit like a fool here, having tried nearly every other setup on the openvpn server config page. I tried with and without forcing all local traffic through vpn but no change whatsoever, I tried not providing domain name or dns, but no change either.

    Can you help me understand what I am doing wrong ?

    Thanks in advance,

    Thierry


  • Did you tried another browser?


  • Hi Bob, thanks for your suggestion. I just tried with Chromium browser with same result : Google ok, get results but no luck afterwards...
    I'll install Chrome just to make sure.


  • Google Chrome : same result.


  • So you have this problem with all clients, windows and linux and different browsers? Maybe you should post screenshots of your serversetup.

  • LAYER 8 Rebel Alliance

    Show your OpenVPN settings and Firewall Rules.

    -Rico


  • Problem solved thanks to your question Rico ! When I created the vpn server(s), the wizard had added the inbound rules but no rule was defined for the outbound traffic coming from the tunnel (10.0.9.0/24).
    I just added a rule to allow any outbound traffic from that subnet on the same interface and now ot's working !
    The symptom of Google search working was strange though, but I guess a state was created in the fw and that it kept being used after the vpn was setup.
    Many Thanks,

    Thierry

  • LAYER 8 Rebel Alliance

    Glad you have it working now.
    The Google Searchbox probably came out of your browser cache. 😉

    -Rico


  • @Rico Well, thanks but no, it's not only the Google search box but also the search results that kept appearing.
    ...and btw, I just noticed that my Microsoft Teams client was still not working when vpn is on
    So, more research to do !