lighttpd taking > 30% cpu



  • Just upgraded my pfBlockerNG to the current package as of today...

    Before, the "pfBlockerNG DNSBL Web Server" aka lighttpd would spike it's use +10-15% randomly with (near as I can tell) nothing using it... now it's hitting 30-40% of my CPU with this version.

    Searching for lighttpd in this forum and others, it appears to have a jaded history of similar behavior for various reasons.

    Is anyone else seeing this?

    Other than abandoning pfBlocker, is there anything that can be done about it?

    Lastly, I am 99% sure nothing on my LAN is is causing it THAT much traffic especially considering lighttpd is only supposed to be serving a 1x1 pixel in place of an ad...

    Bob



  • Okay... sorry to follow up my own post... but a reboot seems to have helped lighttpd for whatever reason... it's CPU use appears to be back to reasonable levels.

    Bob



  • I'm having the same issue as well on an SG-2440 running 2.4.5. reboots have not fixed the problem. Turning off the pfblockerng service does. Is there really only a couple of us having this issue?



  • @gabacho4 said in lighttpd taking > 30% cpu:

    Turning off the pfblockerng service does

    Leave it on. With the default settings. With no feeds what so ever.
    Now you have the same config as I have, and the same as the author has. he wouldn't release it if it would explode the usage of certain( lighttpd ) processes.
    All will be fine - guaranteed.

    Now, add your feeds - your config, step .... by ... step...... and test a lot.
    As soon as you see strange things, like lighttpd going haywire, undo that step - reboot, drink cofee, take a break, and test that step ones more.
    Still a no go ?
    Detail your step on the forum : you'll be having something that can be reproduced. That's worth a lot !
    If you find something : do not forget to detail your entire setup without omitting anything.

    Btw : You could even disable lighttpd, as it only servers a 1 by 1 pixel in most times (I guess, never tried it).

    @gabacho4 said in lighttpd taking > 30% cpu:

    Is there really only a couple of us having this issue?

    Just you ;)
    tazmo resolved the issue by putting things in place. A reboot is rarely needed, but it never hurts.


Log in to reply