400 Bad request | The plain HTTP request was sent to HTTPS port | nginx



  • Hello people! Maybe, I'm from Brazilian and maybe English isn't that cool.

    I ended up activating https through the Webconfigurator interface and port 80 was specified. After I applied, this error is occurring when trying to open the web interface. I can access through the terminal via putty, does anyone have any idea how to fix it?

    Thank you!



  • Hi,

    Several options.
    Console option 15 would be fine. Select a config backup that was made just before the time you changed settings.

    Just keep "80" for plain http, and some other port for https.
    See also what "WebGUI redirect" does, and "HSTS" !!

    Also, it is very advisable to use a certificate that your browser accepts as "signed by a known authority" which means : do not use the self (pfSense) generated cert.



  • @Gertjan, obrigado!

    Fiz a restauração através do console, opção 15, agora consigo acessar as configurações através do Webconfig. Teve um detalhe, eu tive que efetuar o restar do webconfigurator, depois disso foi possivel logar no Webgui.

    Mais uma vez, obrigado!


Log in to reply