[SOLVED] haProxy | lets encrypt wildcard | nur für Server im LAN | es funktioniert nicht



  • SOLVED


    DNS Resolver
    susi.domain.xxx -----> 10.0.0.138 (ip der susi box)
    auf
    susi.domain.xxx ----> 10.0.0.1 (ip der pfS box LAN)
    ändern
    und es funktioniert


    so denn hier auch mal in DE.
    es sind keine Ports nach außen auf der box offen
    die hosts sollen und dürfen dort auch nicht hin

    Ziel ist es die (self signed certificate Meldung in den Browsern zu vermeiden / abzuschaffen)

    41f09aa7-adca-4b8a-acb9-fe398d1ebaf6-grafik.png

    • ACME Cert mit API Key erstellt und alles erfolgreich druchgelaufen
      (alles grün kein error / kein failure )

    haProxy Backend
    47d62e41-cbda-4e89-9c6c-da1dbd611455-grafik.png

    active -- host.domain.xyz -- Adress+Port -- IP-Adress -- 443 -- yes -- yes

    haProxy frontend
    1c8d395a-2472-4476-a62a-720af09997f2-grafik.png

    3efff9e2-1a12-4f44-9287-9c1a6e3eef42-grafik.png

    afc27806-b0a9-413a-9f51-9f63719ae606-grafik.png
    c4ff0326-f5fd-4be5-a77d-65c7f41f66f6-grafik.png

    the value for (host matches) ---> host.domain.xyz

    3a53b01f-9788-4a23-b2ac-8df6f48c7078-grafik.png

    the Backend in (Actions) ---> das Backend jenes zuvor erstellt wurde.

    6415aaac-c447-4aad-bb48-b20ba90ca821-grafik.png

    e390d945-be82-4a59-8e37-4af55f335862-grafik.png hier (Certificate) das von acme erstellte Zertifikat auswählen

    1d1ccf74-cff4-4c96-980f-bb590be797e0-grafik.png

    alles andere bleibt so wie es ist

    -edit1-
    da die hosts nur aus dem internen netz erreichbar sein sollen wird mittels (Host overrides)
    die IP noch hinzugefügt name gleich wie Backend (host.domain.xyz)
    und das pro host
    16099fa5-63ae-44a0-a0bf-0ffaef501df6-grafik.png
    f0cfbbbc-8aa0-4ab9-a2e1-cdb576d2beb8-grafik.png

    -edit2-
    sonderfall 1
    (auf der box läuft ein pfBlockerNG)
    die domain wurde als wildcard bereits in DNSBL gewhitelisted

    sonderfall 2
    8d4a8524-16e9-4d2d-952c-97981cf8ef21-grafik.png
    fa96b6ee-0197-4205-b48e-92f3d51dee15-grafik.png
    fe8a39cc-ce26-49b4-8d39-5aecfbf2413c-grafik.png

    die frage die sich mir gerade aufdrängt weil es nicht funktionier ...
    wie prüf ich ob die die requests überhaupt über den HA proxy laufen ?
    denn scheinbar krankt es genau daran.


Log in to reply