Managing stream5: TCP session without 3-way handshake Events



  • I am getting lots of these events generated. Within the snort.conf file, I've already set this up: "require_3whs 180".
    9504032c-224f-479b-9a13-e1b9862564bb-image.png



  • Are you running the Snort package on pfSense? If so, you should never edit the snort.conf file directly because it is overwritten each time Snort is stopped and restarted in the GUI. There is an option checkbox within the package GUI on pfSense for enabling that require_3whs parameter on specific host targets.

    From the screenshot you posted. and the fact your mention editing the snort.conf file directly, it appears like you are not using the pfSense Snort package.

    If you are not running on the pfSense firewall distro, please note this forum is only for support of the Snort and Suricata packages available for pfSense. Apparently Google or some search engine has been sending a few folks here of late that are actually running an IDS/IPS on some other platforms such as Linux.

    The feature you mentioned, "require_3whs", is a target-based option within the Stream5 configuration. The official Snort binary manual that describes this is here: http://manual-snort-org.s3-website-us-east-1.amazonaws.com/node17.html.


Log in to reply