OpenVPN client (AirVPN) packetloss when high traffic



  • Hi All,

    Looking for some help before my brain explodes trying to figure this out. I've hunted all the forum posts and still not getting any where.

    I have setup AirVPN UDP OpenVPN client on my pfSense, this all works fine, but I have an issue when I max out my connection downloading a file, I see packet-loss on the gateway. (Tested on some other providers and get the same thing)

    alt text

    Changed the connection to TCP and I don't experience the same issues.

    Have checked with my ISP theres no throttling etc applied to my connection, only see this when I max out my connection downloading. Doesnt seem to be a CPU issue and theres plenty of RAM available.

    Any help on how I can investigate/resolve this would be great.

    Thanks



  • Hi Stevetoza,
    I had the same problem and I've fixed by check the "Don't pull routes" option, for every OpenVPN clients, under VPN / OpenVPN / Clients, as you can see below:

    180ce15c-40f5-41bd-b060-fdc43511ad9f-immagine.png

    Now, all the OpenVPN gateways appears like this, without packetloss also on high download rate:

    8e8f85eb-4c4b-4ff3-95cb-1237342f794b-immagine.png

    I confirm that my OpenVPN clients are connected to servers via UDP.

    Hope this works also for you!



  • @dubatech - many thanks, looks like this has resolved the packet loss on the VPN gateways while using high download rate. I now end up with packet loss on my WAN gateway when high download rate via the vpn



  • @stevetoza, do you use your VPNs_WAN in a WAN_group and enabled "Use sticky connections" under System / Advanced / Miscellaneous / Load Balancing?



  • @dubatech said in OpenVPN client (AirVPN) packetloss when high traffic:

    do you use your VPNs_WAN in a WAN_group and enabled "Use stick

    I do use the VPN_WAN's in a group and have enabled sticky connections, but I'll try disabling that now, as I've tiered the connections as a fail over



  • @dubatech I have another question regarding the picture you have posted? Looks like you do not use a Monitor IP for the gateways and it is pinging the internal gateway IP (0.2ms and 0.3ms). This will never reveal a real packet loss right?



  • @stevetoza Did you try adding a Monitor IP like Google DNS and see how it reports packet loss? I too have an average of 0.02% to 0.05% packet loss with NordVPN but this has nothing to do with load and is very random. It could also be that some hop is ignoring ICMP packets under load and not a real packet loss.

    I had larger packet losses before but I adjusted the MTU and it went down. Right now I have mssfix 1370.



  • @nirmalts the monitor ip is the VPN_WAN gateway of each VPN client but when I didn't check "Don't pull routes" I was suffering packet-loss.

    VPN2_WAN without the "Don't pull routes" RTT is 8.1ms and I use it as the default route (0.0.0.0), using it for dns over vpn with the internal vpn dns ip.


Log in to reply