WLAN: langsam und hoher paketloss



  • Hallo Leute,

    ich habe meinem pfSense-Router eine WLAN-Karte mit Atheros-Chipsatz gegönnt, um meinen alten WLAN-Router endgültig in Rente schicken zu können. Die Installation klappte mit der pfSense-Version 1.2.3-RC1 anfangs problemlos. Ich habe die SSID gesetzt, den WPA2-Key und Firewall-Regeln erstellt und DHCP für das neue Interface aktiviert und mich anschließend direkt mit meinem Vista-Laptop mit dem WLAN verbinden können.

    Nach kurzem Check machte sich dann aber Enttäuschung breit: Die Internetverbindung funktioniert nicht wirklich, ich habe übers WLAN extrem hohen paketloss und Surfen ist eigentlich nicht möglich. Pings auf heise.de schwanken zwischen 20 und 600 ms (LAN: 10-15 ms). Die Signalstärke zum WLAN wird hingegen als hervorragend mit 54 MBit/s Übertragungsrate ausgewiesen.

    Weiss jemand Rat?

    Routerhardware:
    AMD X2 3800+
    1 GB RAM
    AMD 690G-Chipsatz
    Intel 1000 MBit Dual LAN PCI-X (LAN/WAN)
    TP-Link TL-WN851N (300 Mbit/s WLAN / Atheros-Chipsatz)

    Client ist ein Centrino-Laptop mit Intel WLAN-Karte (draft-n).



  • Schau' mal, was auf dem benutzten WLAN Kanal oder auf Nachbarkanälen noch an APs funkt.
    Ein hoher Packet Loss klingt in dem Zusammenhang eher nach Funkstörung.



  • Danke für die Antwort.

    Ih habe heute etwas mit den WLAN-Kanälen, der Verschlüsselung mittels WPA/WPA2 und der "Transmit Power" herumgespielt. Zusätzlich habe ich mir ein Acer Aspire One mit Atheros WLAN-Karte und Win XP besorgt, um meinen Client als mögliche Fehlerquelle auszuschließen. Gebracht hat es leider alles nichts, gleiches Verhalten wie zuvor auch.

    Es ist durchaus möglich Seiten anzusurfen und mit sehr viel Geduld sogar eine SSH-Session mit meinem Rootie aufzubauen, der Speed ist aber einfach unterirdisch. Das wundert es mich schon sehr. Die Verbindung steht, DHCP und DNS scheinen zu funktionieren, die Signalstärke ist hervorragend und trotzdem läuft es alles andere als rund.

    Über WLAN:

    Pinging 192.168.1.1 with 32 bytes of data:
    
    Reply from 192.168.1.1: bytes=32 time=458ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=391ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=428ms TTL=64
    Reply from 192.168.1.1: bytes=32 time=464ms TTL=64
    
    Ping statistics for 192.168.1.1:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 391ms, Maximum = 464ms, Average = 435ms
    
    Pinging 192.168.1.1 with 32 bytes of data:
    
    Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
    Request timed out.
    Request timed out.
    Reply from 192.168.1.1: bytes=32 time=176ms TTL=64
    
    Ping statistics for 192.168.1.1:
        Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 0ms, Maximum = 176ms, Average = 88ms
    

    Über LAN werden die Pings immer mit <1ms ausgegeben. Analog verhält es sich auch mit Seiten im Internet.

    Hat jemand noch eine Idee? Ich bin derzeit ziemlich ratlos…  :(



  • Sorry, weitere Erfahrungen habe ich nicht.
    Als Idee würde ich zuerst nachschauen, ob die W-Lan Karte bzw. der Chipsatz unter FreeBSD offiziell unterstützt werden.
    Dann käme noch ein IRQ Problem in Betracht.

    Das sind aber nur Ideen, wo ich ansetzen würde zu suchen…



  • @icebeer:

    Nach kurzem Check machte sich dann aber Enttäuschung breit: Die Internetverbindung funktioniert nicht wirklich, ich habe übers WLAN extrem hohen paketloss und Surfen ist eigentlich nicht möglich. Pings auf heise.de schwanken zwischen 20 und 600 ms (LAN: 10-15 ms).

    Ich hatte auch mal ne WLAN Karte in pfSense. Bei mir wars so, dass Seiten meist nicht geladen haben. Wenn ich jedoch gleichzeitig irgendwohin ins Internet pingte, funktionierte allerdings das Surfen.

    Ich hatte dann unendliche viele In/Out Errors auf dem WLAN Interface. Da gibts auch in Wireless einen (allerdings englischen) ellenlangen Tread dazu. Ob das mittlerweile allerdings gelöst ist, weiss ich nicht. Momentan hab ich kein WLAN aktiv. Sieh mal nach ob Du auch die Errors hast und guck dir ggfs. mal den Thread an.



  • deaktiviere mal den ACPI Modus damit ging es dann bei mir Problemlos hatte das gleiche Problem seit dem alles i.O.



  • Danke für die Tips. :)

    Ich habe heute zuerst die Steckplätze der WLAN und LAN/WAN-Karte getauscht - ohne Erfolg. LAN/WAN funktionierte weiterhin super, WLAN wie zuvor.

    Leider bootet mein System ohne ACPI-Modus nicht. Er meint er könnte einem unbekannten Gerät keine Ressourcen zuweisen und bleibt dann bei der Meldung IPSec initialisieren zu wollen stehen. :(



  • ne schreib das in die letzte Zeile hint.acpi.0.disabled=1 von der Datei /boot/loader.conf



  • Genau das habe ich gemacht mit oben beschriebenem Effekt. Das System bootet dann leider nicht mehr hoch, ich muss beim Booten ACPI wieder aktiv schalten, damit es startet.



  • Haste auch im BIOS ACPI deaktiviert weis jetzt nicht mehr wie es bei mir ist da das ding immer läuft und eh keinen Monitor hat aber schon komisch.
    Vielleicht musste noch eine Option da aktivieren im BIOS!


Locked