Driver support for Intel Dual Band AC 7260



  • Hi all,

    I just installed an Intel® Dual Band Wireless-AC 7260 on my pfsense machine. both the card and the motherboard that im using support PCIe 2.0 which is required for this card. I had a look at the FreeBSD forums and found out that they have supported drivers for this card on FreeBSD. see link below
    https://www.freebsd.org/cgi/man.cgi?query=iwm&sektion=4&manpath=FreeBSD+12.1-RELEASE+and+Ports

    Im not very technical with linux/freebsd but i have a basic knowledge and can run through guides. Could someone please tell me how i can add these to the kernel on pfsense?


    To compile this driver into the kernel, include the following lines in
    your kernel configuration file:

       device iwm
       device pci
       device wlan
       device firmware
    
     You also need to select a firmware	for your device.  Choose one from:
    
       device iwm3160fw
       device iwm3168fw
       device iwm7260fw
       device iwm7265fw
       device iwm8000Cfw
       device iwm8265fw
    
     Or	you can	use
    
       device iwmfw
    
     to	include	them all.
    
     Alternatively, to load the	driver as a module at boot time, place the
     following lines in	loader.conf(5):
    
       if_iwm_load="YES"
       iwm3160fw_load="YES"
       iwm3168fw_load="YES"
       iwm7260fw_load="YES"
       iwm7265fw_load="YES"
       iwm8000Cfw_load="YES"
       iwm8265fw_load="YES"
    

    DESCRIPTION
    The iwm driver provides support for:

       Intel Dual Band Wireless AC 3160
       Intel Dual Band Wireless AC 3165
       Intel Dual Band Wireless AC 3168
       Intel Dual Band Wireless AC 7260
       Intel Dual Band Wireless AC 7265
       Intel Dual Band Wireless AC 8260
    


  • Netgate Administrator

    Copy the the iwm kernel module and firmware from an equivalent FreeBSD install, load it that far far easier than recompiling the pfSense kernel.

    Be aware that iwm does not support hostap mode though, you can only use it as client.

    Steve



  • @stephenw10
    Thanks for replying. I'm really keen to get this working. I actually wanna use this adaptor in hostap mode. Is there any other driver that i can use for this adaptor that also supports hostap?

    are iwn drivers the same as iwm drivers? because when i look at the supported drivers matrix by pfsense, i can see iwn doesn't support hostap. but i see no reference to iwm drivers.

    Also when you say copy the kernel file from another build, can this be found over the net? as i have no other pfsense machine that has this adaptor already working on it.

    Thanks again :)


  • Netgate Administrator

    I think iwm probably didn't exist when that wifi document was compiled.

    There is no other driver for that card. It can't, yet, work in hostap mode.

    You can get the modules from a FreeBSD ISO file. They need to be at least close to what pfSense is running though. I would try a FreeBSD 11.3 ISO first for pfSense 2.4.5

    Steve



  • @stephenw10

    Ok sure, I have downloaded a FreeBSD 11.3 ISO, could you please guide me through where I have to look for those modules? and where I have to copy them on my pfsense machine? please let me know of the directories as Im very new to FreeBSD and don't know where i have to look for stuff.

    Also, Can you please recommend a Wireless card that supports 802.11ac and is Mini PCIe form factor (supported on PCIe 1/2) and is supported by pfsense? (if you know of any)

    Thanks again in advance.


  • Netgate Administrator

    Put if_iwm.ko in /boot/modules and iwm7260fw in /boot/firmware. You can get them from the ISO file directly.

    Try to load it at the command line first.

    There is currently no 802.11ac support in FreeBSD and hence pfSense. That should change at some point (hopefully soon) but there is no ETA.

    Steve



  • @stephenw10
    Thanks Steve, I copied across the .KO files you mentioned and added the following lines to the loader.conf(5):

    if_iwm_load="YES"
    iwm3160fw_load="YES"
    iwm3168fw_load="YES"
    iwm7260fw_load="YES"
    iwm7265fw_load="YES"
    iwm8000Cfw_load="YES"
    iwm8265fw_load="YES"

    After rebooting pfsense, i can see the kernel shows all the above lines right at the beginning, but still after it's fully loaded, im not able to see the wireless card under the available options for wireless interface in the gui. Any thoughts on that?

    EDIT: using this command in shell "pciconf -lv" gives me the below output, which confirms that it sees the card:

    none2@pci0:4:0:0: class=0x028000 card=0x40708086 chip=0x08b18086 rev=0x73 hdr=0x00
    vendor = 'Intel Corporation'
    device = 'Wireless 7260'
    class = network

    So is there a way to enable this card through command so it can be used inside pfsense?


  • Netgate Administrator

    It looks like that should be supported:
    https://github.com/pfsense/FreeBSD-src/blob/RELENG_2_4_5/sys/dev/iwm/if_iwm.c#L5842

    So check the module did actually load using kldstat. Look for errors in the boot log.

    Steve


  • Netgate Administrator

    iwm was actually just added to 2.5 recently so if you want to test the card you could upgrade to that. There's no easy way to downgrade though.
    It will probably be in 2.4.5p1 also.

    [2.5.0-DEVELOPMENT][admin@fw321.stevew.lan]/root: kldstat -v | grep iwm
    		161 pci/iwm
    		166 iwm7265Dfw_fw
    		165 iwm7265fw_fw
    		164 iwm7260fw_fw
    		163 iwm3168fw_fw
    		162 iwm3160fw_fw
    		168 iwm8265fw_fw
    

    Steve



  • @stephenw10
    You are correct it works in version 2.5 but not 2.4.5. Thank you again ☺

    ce80cf8f-ed74-4d5b-81f4-0a1a4e97d934-image.png


  • Netgate Administrator

    Ah, nice. As I say it's just been added to the 2.4.5p1 build list so it should be supported there too when that is available.

    Steve



  • @stephenw10

    Seems no support for Access Point mode as of yet.

    Ted


  • Netgate Administrator

    Indeed, no hostap mode. I'm not sure that hardware can support it. It's unlikely to in FreeBSD/pfSense anytime soon, in any version.

    Steve


Log in to reply