found how to make open vpn client show public ip of server



  • Re: OpenVPN not masking users public IP (to the public IP of the gateway)

    I came across the old post when I was trying to figure out how to resolve my client showing its own public ip instead of my network.

    I use the OpenVPN to connect to devices in my lan, previously I used Netgear's very easy setup so it took me a while on pfsense just to get it running.

    I was satisfied that I could connect to my lan but unsure what it meant to have my clients public ip showing when for a year I was always showing my lans public ip when use the open vpn from my netgear router

    when i was following the manual set up for my paid vpn provider i came to the Additional steps to route wan through tunnel

    I had to
    select Interfaces and click (assign).
    click the + and pick my openvpn in my case it was OPT1 and click save
    Navigate to Interfaces > OPT1
    General Configuration
    Enable: Check this box
    save and apply

    I then connected from my client and check my public ip and it was SOLVED!!!!



  • @jontabaco

    dont know why but the supposed fix only worked for one day and nothing ive tried has resolved my remote ip from showing