Error Configuring dataplane



  • Hi. I am trying to configure the eval for TNSR. I am trying to add NICs to the dataplane. When I try to make any changes through clixon_cli I get an error about the API or dataplane being offline. FYI I am attempting an install on a machine with Broadcom NICs and 8 GB or RAM, not sure if that would cause this behavior.

    IMG_20200506_105244.jpg


  • Rebel Alliance Developer Netgate

    Is VPP actually running when you get that error? Anything errors in the logs? Check sudo journalctl -xe and scroll back a bit.



  • VPP is not running and DPDK is complaining about unsupported interfaces. VPP ins complaining about TLS CA certs. I just ordered an Intel I350 based NIC but VPP should still start without DPDK, right?

    alt text


  • Rebel Alliance Developer Netgate

    The TLS error isn't a problem in this case, but the unsupported device is.

    The device IDs in those errors correspond to the Broadcom NICs.

    You might try setting one of the alternate drivers like uio_pci_generic:

    https://docs.netgate.com/tnsr/en/latest/setup/setup-vpp-interfaces.html#troubleshooting

    Once you set that, restart the dataplane and see what happens.



  • I tried changing the driver and I see less errors in journalctl but I still can't commit the changes or restart the dataplane because VPP is not running.


  • Rebel Alliance Developer Netgate

    You may want to reboot after changing the driver to ensure the right driver is fully attached. I think it shouldn't matter since they were not active before, but I know a reboot is needed when changing from one driver to another.

    It may just not run on that particular hardware, though I am not 100% certain on that. I don't recall mentions of it running on Broadcom, mostly I've seen Intel, Chelsio, and Mellanox if I remember right. You may want to ping your contact for the eval with more info about your NICs


Log in to reply