Error when attempting to issue show packet-counters command

  • As indicated in the subject, I am getting an error when I issue a “show packet-counters” command. The error I get is:

    TNSR tnsr(config)# show packet-counters
    May 7 20:38:45: clixon_xml_parseerror: 198: XML error: xml_parse: line 21: syntax error: at or before: =: XML parse error
    May 7 20:38:45: be_downcall: 600: Protocol error: failed BE RPC packet-counters
    Protocol error: failed BE RPC packet-counters

    In the past I’ve restarted the dataplane service and fixed this issue...I think. No such luck this time around. Any ideas?

  • Rebel Alliance Developer Netgate

    From a shell, can you try sudo vppctl show node counters? Or from within TNSR you can run that as shell sudo vppctl show node counters. What does that output? Or does it also generate an error?

  • Ran the requested command from tnsr and got output that I would expect to see running the show packet-counters command. What does that tell you Jim?

  • Rebel Alliance Developer Netgate

    What exactly was in the output? Can you paste it here? I wouldn't expect an error unless maybe there was something unexpected in that output.

  • The outout I get invoking your suggested command is:

    TNSR tnsr# shell sudo vppctl show node counters
       Count                    Node                  Reason
         12651               dpdk-input               no error
             6          dhcp-proxy-to-client          DHCP packets for local client.
             3         ip4-dhcp-client-detect         Extract
             1           dhcp-client-process          DHCP discover packets sent
             2           dhcp-client-process          DHCP request packets sent
             2           dhcp-client-process          DHCP bind success
        110611          acl-plugin-out-ip4-fa         new sessions added
       8704269          acl-plugin-out-ip4-fa         existing session packets
       8814880          acl-plugin-out-ip4-fa         checked packets
           179          acl-plugin-out-ip4-fa         restart session timer
            14          acl-plugin-in-ip4-fa          ACL deny packets
        125341          acl-plugin-in-ip4-fa          ACL permit packets
       6507328          acl-plugin-in-ip4-fa          existing session packets
       6629562          acl-plugin-in-ip4-fa          checked packets
           119          acl-plugin-in-ip4-fa          restart session timer
          1701                arp-reply               ARP replies sent
            14                arp-reply               IP4 source address not local to subnet
            16                arp-reply               ARP request IP4 source address learned
             6              arp-disabled              ARP Disabled on this interface
             6                arp-input               IP4 destination address is unset         2                ip4-glean               ARP requests throttled
            90                ip4-glean               ARP requests sent
             1                ip4-input               ip4 ttl <= 1
          5435                ip4-input               Multicast RPF check failed
             1             ip4-icmp-error             hop limit exceeded response sent     13670             ip4-icmp-input             echo replies sent
           664               lldp-input               lldp packets received on disabled interfaces
          3354                llc-input               unknown llc ssap/dsap
            22       GigabitEthernet4/0/0-output      interface is down
            27     TenGigabitEthernet6/0/0-output     interface is down
            27     TenGigabitEthernet6/0/1-output     interface is down
            27     TenGigabitEthernet8/0/0-output     interface is down

    I tried the normal command once more for kicks and still get the error I reported earlier. Also, an running an up to date 20.1-1 instance in an SG-5100 just have all the variables.

  • Rebel Alliance Developer Netgate

    1 ip4-input ip4 ttl <= 1

    I bet it's that.

    Are there really missing line breaks in a couple places there? Or was that just a copy/paste issue?

  • Screenshot_20200507-231747.png

    Screenshot from my phone just to avoid any copy and paste format fun.

  • Sorry about those breaks. I hadn't noticed them when I copied from the terminal.

  • Rebel Alliance Developer Netgate

    That's OK, I figured it was just a copy/paste issue but wanted to be certain.

    I'll work that info into a bug report, thanks!

  • Thanks for your understanding. So I've helped find a bug? Cool deal. Glad I could contribute to the cause. Any idea how long you think that one would take to correct? I'm not sure where it would fall on your list of priorities. In the meantime, I can always run the command you suggested. Pleasure interacting with you yet again!

  • Rebel Alliance Developer Netgate

    Actually it looks like we already had one open for that. It's slated to be fixed in our next release (20.06) which isn't too far off.

    In the meantime, you can run the vppctl version of the command to get the output.

  • Way to make a guy feel redundant 😜

  • @gabacho4 - Thanks for all the great feedback and questions!

  • @audian no problem at all! I'm enjoying the TNSR experience and look forward to seeing the fixes and improvements you all are working on.

Log in to reply