Wireless WAN causing crashes when switching interfaces

  • Hey! I'm sort of a newbie with pfSense, but I have recently found a better (or so I thought) way of getting signal from my modem to my pfSense box, without running cables, because my building will not allow it. I started to set the WiFi nic up for the WAN interface, and it started out okay. Unfortunately, it has now developed a new habit of attempting to initialize and connect, but then make my pfSense box crash. (Specifically, I am using a USB nic, the TL-WN725N Nano adapter from TP-Link.) I've got the module for it, and it does see the card and I did set up a wireless interface, but it always crashes as soon as I set the WAN parent interface to the wireless interface. Does anyone have any suggestions? I've tried looking all over the forums, and nothing has worked. At this point, I don't know what to do.

  • Most probably the usb/wifi driver is problematic and crashes at the os level.

    Generally this isn't a good idea and you will have problems.
    An access point in client mode would supply ethernet connectivity and would work much better.

  • I do understand this, but I am unable to run cables in the building. I already have an access point that is supplying the WAN for my router, but the router is what is crashing. I have seen posts of other people on here getting the same driver and nic to work in this way. I am not sure what I’m doing wrong, but I sure would pile to know.

  • @netblues - on the right way ("Generally this isn't a good idea and you will have problems.")
    TP-LINK TL-WN725N v2 = Realtek RTL8188EUS

  • Alright, I've decided to not use this adapter, as I have found a way to run a cable.

  • Netgate Administrator

    Is it actually that or a Ralink device? How does the interface appear?

    The Ralink NICs have always crashed in infrastructure mode for me, though they seem fine in hostap mode.


  • The interface appears normally, but it crashes every time. Anyways, I've given up on this.

  • Netgate Administrator

    I meant like is it run0 or rsu0 or something else.

  • I can't remember, but I think it was something else.

  • Netgate Administrator

    Ok, no worries.

Log in to reply