Gen2 - pfSense 2.4.5-p1 - elf64_loadimage: read failed - Windows 2012R2 Hyper-V



  • Hello, I tried to upgrade some of pfSense 2.4.4-p3 installations in virtual environment to new 2.4.5-p1 version. On Hyper-V 2016 & 2019 everything was ok, but on Windows 2012R2 Hyper-V not. After upgrade, pfSense is not able to boot with message "elf64_loadimage: read failed".
    So I tried make a new installation but booting installation CD is ending on the same message. Then I tried boot CD on Generation1 VM and everything is ok. So there is problem "only" on Windows 2012R2 Hyper-V Generation2 VM.

    Edit: I tried to boot pfSense 2.5 DEV and it is the same. So I think that it is time to move to newer Hyper-V or reinstall VM as Gen1.


  • Rebel Alliance Developer Netgate

    I'm not sure what options are available in that version, but if there is an option to use UEFI vs legacy boot, try changing that.



  • Generation 2 virtual machine in Hyper-V is able boot only in UEFI mode. If you want to boot in legacy mode, you must create generation 1 virtual machine. And you are not able switching between gen1 and gen2.



  • I've got the same issue. I'm running 2.4.5 without any issues on a gen 2 VM on 2012R2. If I try to upgrade then it looks like it works until the reboot. The display ends up really mucked up and it reports back that it "can't load 'kernel'".

    hyper-v_error.png

    Like DD, I tried doing a fresh install of 2.4.5-p1 on a gen 2 VM and get the same error message. I'd rather avoid a gen 1 VM if I can. @DD I'm glad to hear it works with 2016 and 2019... guess I need to start planning my host upgrade :/



  • Well it works fine with 2.4.4-P3 so something is wrong with the ISO 2.4.5-p1.. But upgrade fails .. Well I have to upgrade as well. then, but Wish Netgate could confirm this... but hell 2012 is EOL soon.. :)


  • Rebel Alliance Developer Netgate

    @Axachi said in Gen2 - pfSense 2.4.5-p1 - elf64_loadimage: read failed - Windows 2012R2 Hyper-V:

    Wish Netgate could confirm this...

    Being an Open Source-focused business, we do not have much in the way of Windows systems around. Especially servers. Systems which can run Hyper-V are even more scarce compared to VMs and such used for various testing. So it's unlikely we'd confirm anything unless it's a problem on Azure or maybe something reproducible on the most recent version of Windows 10 at the time.

    There may be an issue with kernel size, we did add some more drivers to 2.4.5/2.4.5-p1, but it sounds like you're hitting a limitation of the platform being used, not pfSense. We can't always accommodate every variation of every platform, especially ones that are nearly EOL.



  • I also had this issue when trying to upgrade to 2.4.5_1 on Windows 2012R2 Hyper-V. I had to restore a 2.4.4 backup to get it working again. I'll have to stay on that version indefinitely if Netgate won't fix this.

    Note that Windows 2012 R2's end of life is October 2023, over three years away. So it is no way "nearly EOL".



  • @asdkjw I think that this error will be never fixed because it is old error with UEFI - http://freebsd.1045724.x6.nabble.com/failing-to-install-11-1R-on-VMWare-td6249644.html or http://freebsd.1045724.x6.nabble.com/Boot-failure-svn-up-from-this-morning-td6170968.html
    Solution is to reinstall pfSense on Hyper-V 2012R2 as Gen1 VM and then everything will be working ok. It is same in pfSense 2.5 version.


Log in to reply