Turn off OpenVPN Password required on boot



  • Hi,

    Whenever we try to restart the pfsense firewall it gets stuck on "Enter Auth Password:" and we'd have to enter the admin password to let it continue to boot. Upon further research it turns out its due to OpenVPN having user with password setup instead of certificate.

    Is there is any way to bypass this problem because we don't have direct access to our pfsense device and every time we have to restart the device we lose connection to the entire network and since we are all at remote location and the server is 3000+ miles away its not ideal and costs us money for the downtime.

    I would therefore like to request or figure out a way to disable that "Enter Auth Password:" on boot which is due to OpenVPN, setting up a certificate authentication instead of password authentication is not an option. we don't want to configure that and don't really understand the reason why OpenVPN wants the password on boot.


  • Global Moderator

    Be sure that User Authentication Settings on the OpenVPN client configuration page not empty:
    Screenshot from 2020-06-25 13-23-52.png

    Fill in the username and password fields


Log in to reply