OpenVpn client cannot access subnet via Draytek IPsec to Pfsense tunnel



  • Hi everyone.
    Im new to prsense and openvpn so please bare with me. I've literally spent all day on this. I have a situation and i've seen similar posts already and they do not help so;

    I have 2 sites (Office + Cloud)
    These are connected via an IPSEC tunnel (Draytek to Pfsense)
    I have an openvpn server on the pfsense which works fine.
    What I cannot do though is ping/map drives to the Office. I can access the cloud site fine.

    Office - 192.168.7.0
    Cloud - 192.168.50.0
    OpenVPN - 10.0.50.0

    I have on the draytek side, added a route via the ipsec tunnel.
    alt text

    On the Pfsense, Server I have
    P1
    IPv4 Local network(s)
    192.168.50.0/24,192.168.7.0/24

    P2
    alt text

    Firewall Rules
    alt text

    alt text

    On the desktop pc for which I have an active openVPN link up, I can ping both 10.0.50.1 and a pc on the cloud network 192.168.50.1
    I cannot access 192.168.7.x

    From dos, running route print shows that the openvpn client has added the correct route
    alt text

    however the pfsense is either not redirecting traffic or i've done something wrong.

    Tracing route to 192.168.7.254 over a maximum of 30 hops
    
      1    21 ms    18 ms    17 ms  10.0.50.1
      2     *        *        *     Request timed out.
      3     *        *        *     Request timed out.
      4     *        *        *     Request timed out.
      5     *        *        *     Request timed out.
    


  • don't worry - i've sorted it.


Log in to reply