Пропадает связь с WAN, что делать?



  • Начала пропадать связь с WAN интерфейсом, причем внезапно, роутер может проработать день и потом отрубить его, или через 20 минут. Сегодня за день отрубал 10 раз. Не могу разобраться из-за чего такое может происходить?
    Проблему решаю входом в меню WAN и нажатием кнопки Save, либо перезагрузкой роутера.
    В инет доступ через шлюз, без всяких VPN. Конфиг - PIII 600MHz, RAM 192MB, HDD 512MB.

    Перерыл все настройки, всё перепробовал, но ситуация не меняется =(



  • На WAN статический IP?
    С самого pfSense пингуется (когда считается пропавшим)?



  • Пингуется. Но шлюз, который идет после него не пингуется.



  • @fus10n:

    Пингуется. Но шлюз, который идет после него не пингуется.

    Кабель?



  • не очень понял, что пингуется, что нет -( махонькую диаграмку сюда?



  • @dvserg:

    @fus10n:

    Пингуется. Но шлюз, который идет после него не пингуется.

    Кабель?

    100% не в нём дело, потому-что мне достаточно проделать действия, которые я в первом посте писал и всё начинает работать.



  • @Eugene:

    не очень понял, что пингуется, что нет -( махонькую диаграмку сюда?

    Пример - провайдер даёт инет со шлюза 192.168.5.1, ip wan - 192.168.5.22, ip lan - 192.168.1.1
    Так вот, 192.168.5.22 и 192.168.1.1 пингуются, а 192.168.5.1 молчит

    Вот диаграмма, если я тебя правильно понял..

    http://img5.imageshack.us/img5/2415/statusrrdgraphimg.png

    http://img25.imageshack.us/img25/8010/statusrrdgraphimge.png



  • Ага, значит в момент когда работает всё сделай из консоли
    arp -an | grep 192.168.5.1
    потом, когда инета нет то же самое и сравни мак адреса.
    можешь скриншот WAN-интерфейса настроек показать?



  • $ arp -an | grep 172.26.20.1
    ? (172.26.20.1) at 00:14:5e:95:75:99 on xl0 [ethernet]

    $ arp -an | grep 172.26.20.1
    ? (172.26.20.1) at (incomplete) on xl0 [ethernet]

    Скрин

    http://img20.imageshack.us/img20/9939/ipconfn.jpg



  • Ну вот как всё просто оказалось - ты просто не видишь свой Gateway даже на втором уровне. Тряси провайдера. Как кстати это подключение физически организовано - выходит CAT5 кабель из pfSense и …..?



  • Стоп стоп стоп ))) Это я сразу понял. До этого у меня стоял ASUS WL-500gp v2 и работал без потери связи целый год. Вместо него я собрал роутер на pfsense и начались вот такие глюки..



  • так что между pfSense и провайдером установлено?



  • Ничего между ними нету. Провайдер воткнут в WAN pfsense. Асус давно снял.



  • не, ну что-то должно быть -)) провод, например. И дальше - CAT5 кабель не может простираться на километры, где-то рядом есть устройство в которое этот кабель воткнут - что это?



  • На сколько мне известно свич у провайдера dlink 3526



  • Я бы снял tcpdump c WAN в момент появления проблемы, где были бы явно видны мои ARP requests и ничего в ответ и очень вежливо спросил бы провайдера почему так происходит.



  • Разобрался с проблемой!! Дело было в сетевухе на WAN которая стояла. Заменил - всё отлично заработало, аптайм неделя уже =)
    Спасибо всем =)


Log in to reply