CaptivePortal not working on vlan interface em0 (pfSense 1.2.3-latest-snap)



  • Hi,

    We're testing with the 1.2.3 release of pfsense, and it seems the captive portal is not working when running on a vlan interface.
    After some troubleshooting it seems ipfw sees the packets going on the parent interface of the vlan, which causes
    the portal to be skipped.

    Is this a bug or something else…. anybody any idea's on this?

    Regards,
    Flip



  • After some more troubleshooting it seems it does work when the CP is on fxp0, but not om em0.



  • It works on fxp0 with VLANs you mean, or on the actual interface without VLANs?



  • I'm the colleague of techq135.
    It does work on a vlan interface with fxp0 as a Parent interface.
    It does not work on a vlan interface with em0 as a Parent interface.
    Everything else is the same, only fxp0 has been replaced by em0 and vice versa.



  • Hello,

    just report vlans and cp is working for me on em(4) devices.

    my system is a core2duo, 4GB RAM, running full install on microdrive and I have 4 interfaces setup as follows:

    WAN (em0)
    WAN2 (em1)
    LAN (em2)
    Procurve (em3 - vlan100)
    DMZ (em3 - vlan22)
    HS (em3 - vlan44)
    VoIP (em3 - vlan55)

    as you can see I have 4 vlans sitting on em3, HS has captive portal enabled and is working fine.

    This is on 1.2.3-RC1 built on Sat May 30 21:39:48 EDT 2009 FreeBSD 7.2-RELEASE i386

    Im pretty sure ive tested in the 7.1 branch and all was fine.

    cheers

    slam



  • I've heard of a couple cases with CP not working on VLANs but I've never been able to replicate it and I know it works fine pretty much always. Not sure what you might be running into, I would say NIC driver related, but I know it works on VLANs on em interfaces (and Slam reported the same). Maybe something specific to a particular em implementation you're using.

    Try a 7.2 based version and see what happens, maybe the newer em driver won't have the same problem.



  • We just started testing with the 1.2.3/FreeBSD 7.2 release and we get the same problem as with the FreeBSD 7.1 release.

    As far as I can see, the em-driver is also the same in both FreeBSD releases. (v6.9.6).

    We are testing on a Nexcom platform. This has a 82541PI-chip based Intel gigabit network adapter.



  • Can you disable the rxcsum and txcsum on this interface?!

    If does not fix things, try disabling hwtagging.



  • We will do some more testing, but at first sight, disabling vlan hwtagging seems to do the trick.

    Seems that we will have to disable this permanently then…., not sure what the best approach is to do this in pfsense.



  • You can use the <shellcmd>tag or there might be something to disable this on System->Advanced on 1.2.x.</shellcmd>



  • Thanks for putting us on the right track with the hwtagging!

    There's nothing for this on the System->Advanced, we'll just add the options to the interfaces php pages of wan/lan/opt, so we can adjust whenever we need via the webinterface.



  • I think I have the same problem.

    I have two 2 em interfaces, one is for wan, one is for a few vlans.
    All the vlans are routing properly, but as soon as I enable captive portal on that vlan interface, that network is not able to access anything at all.

    How do you disable rxcsum/txcsum/hwtaggging?



  • Hi,

    You can disable the hwtagging (hardware vlan tagging) bij issuing a ifconfig <if>-vlanhwtag, for more information see the FreeBSD manpages of ifconfig.
    This can be done with a shellcmd.</if>


Log in to reply