DNSBL: Whitelisted URL still being blocked



  • I have several feeds going into DSNBL, and a manual list. So, when I noticed DNSBL blocking a URL I didn't want it too, I checked my manual lists first. It wasn't there, so I assumed it was coming from an external block list. So, I added that URL (cloudsync-prod.s3.amazonaws.com, with and without "www") to the global whitelist on DNSBL. Still it was blocked, even after an update. So I manually ran a reload, but it was still being blocked. Tried those both a few more times, but still no luck.

    What am I doing wrong here?
    Rules:
    4bf2565d-ab8a-4f4b-b526-2cef78d2b019-image.png

    Log:

    DNSBL Reject HTTPS,Jul 19 16:20:45,cloudsync-prod.s3.amazonaws.com
    

    Thanks!



  • @CyberMinion

    Do you have the "TLD" option enabled in pfBlockerNG/DNSBL? If not, you might give that a try.

    Do not add the "www" to the URL? Add the URL you want to whitelist to the TLD Whitelist screen? If you are unsure about what format to enter the URL, click on the small blue circle with an "i" in it and it will show you what the correct format should be.



  • @jdeloach said in DNSBL: Whitelisted URL still being blocked:

    Do you have the "TLD" option enabled in pfBlockerNG/DNSBL? If not, you might give that a try.

    I do have TLD enabled at present. Are you saying I should try enabling it, or disabling it? I could try disabling it to see if that helps, I suppose, but shouldn't an explicit whitelist rule override that anyway?

    Do not add the "www" to the URL?

    I tried that first, then in desperation tried adding in the "www" entry, in case that helped. Nope.

    Add the URL you want to whitelist to the TLD Whitelist screen?

    Interesting. I didn't try that. I've added this entry in there, and will see if it helps.

    If you are unsure about what format to enter the URL, click on the small blue circle with an "i" in it and it will show you what the correct format should be.

    I'm not using any regex or other dynamic rules, just these static entries. I know they work, because other URLs I have whitelisted unblocked without problems.

    Thanks for the tips!



  • @CyberMinion said in DNSBL: Whitelisted URL still being blocked:

    I do have TLD enabled at present.

    Hello!

    Make sure to follow the "Click infoblock before enabling this feature!" text under the TLD option. There is a section on TLD Exclusions and whitelisting.

    John


Log in to reply