Ntopng doesn't work on pfsense

  • Hey guys! I run into a problem when tried to install and run ntopng on a pfsense vm.

    I installed pfsense as a vm on VM workstation 12 and I can't make ntopng work. I already watched almost every videos, went to every forum/blog and can't make it work. I can easily install the packages, i can configure it fine but when i try to open the web page from ntopng it simple doesn't load.
    I get this message: "This site can't be reached. ... took to long to respond."
    I have pfsense version 2.4.5-RELEASE-p1 and ntopng version 0.8.13_5.
    When I stop ntopng no error's but when i try to start ntopng from the pfsense shell, it says that " ntopng needs to have redis up and running" and i can't make it run even though it is installed and well config. Am I missing something?

    Thank you and best regards,
    André Ferreira

  • I can post any information needed. Just let me know

  • Netgate Administrator

    Does the service show as running? Does the service restart corrcetly?

    Do you see errors logged when you try to reach the page and it fails to respond.


  • Hey Steve, thank you for you help before anything.

    The ntopng service on web pfsense says it's running.
    When i try to stop on pfsense shell it work but when i try to start it on pfsense shell if gives me this error:

    "Starting ntopng.
    31/Jul/2020 16:34:06 [Ntop.cpp:1902] Setting local networks to
    31/Jul/2020 16:34:07 [Redis.cpp:111] ERROR: ntopng requires redis server to be up and running
    31/Jul/2020 16:34:07 [Redis.cpp:112] ERROR: Please start it and try again or use -r
    31/Jul/2020 16:34:07 [Redis.cpp:113] ERROR: to specify a redis server other than the default

    But when i run "redis-server /usr/local/etc/" open another terminal and start ntopng again it says (i need to open another terminal because when i run this command, if i leave it's like the redis service stops running too) :
    "Starting ntopng.
    31/Jul/2020 16:35:27 [Ntop.cpp:1902] Setting local networks to
    31/Jul/2020 16:35:27 [Redis.cpp:132] Successfully connected to redis
    31/Jul/2020 16:35:27 [Redis.cpp:132] Successfully connected to redis
    31/Jul/2020 16:35:27 [Ntop.cpp:1842] Parent process is exiting (this is normal)

    But when i check the ntopng/redis status, " ntopng/redis is not running." even though there is no errors.

    Thank you for your help,
    André Ferreira

  • This post is deleted!

  • Netgate Administrator

    I have seen that error logged a few times in systems running ntopng but it's never actually stopped me accessing it. More like it stops and restarts when that happens.

    In some systems it does that fail after rebooting or restarting the service. I opened a bug for that:

    It logs a different error when that happens though as shown there. Are you seeing that?


  • When i restarting/rebooting the service i get this error like 20-30 times.

    "31/Jul/2020 17:25:19 [Redis.cpp:75] Redis has disconnected: reconnecting..."

    After this error I get:

    "31/Jul/2020 17:26:11 [main.cpp:396] Logging onto /var/db/ntopng/ntopng.log
    31/Jul/2020 17:26:11 [main.cpp:399] Working directory: /var/db/ntopng
    31/Jul/2020 17:26:11 [main.cpp:401] Scripts/HTML pages directory: /usr/local/share/ntopng
    31/Jul/2020 17:26:11 [Ntop.cpp:403] Welcome to ntopng amd64 v.3.8.200529 - (C) 1998-18 ntop.org

  • Netgate Administrator

    Hmm, I'm unable to replicate that. How big is the VM you have this running on? Anything else running on it?


  • I have 6 more VM but nothing is running while I run the VM that has the Pfsense on

  • Netgate Administrator

    Sorry I meant any other packages running in pfSense?

    And what size is the VM? How much RAM? How many CPU cores?


  • Only installed Ntopng, don't have any other packages besides the ones already pre-installed on Pfsense. 35 GB. 4GB RAM and 4 CPU cores.

Log in to reply