• when i install frr in pf2.5, then system dowm.

    photo_2020-08-14_22-53-43.jpg

    photo_2020-08-14_22-53-33.jpg

  • Rebel Alliance Developer Netgate

    That isn't related to FRR. Looks like your entire config.xml is missing or corrupted/unreadable.


  • not, i have been Restore with config.xml file sytem is up, when only Restore install frr will down.
    pf2.4.5 work, pf2.5 down.


  • i have try Restore other Packages, system is normal, only install frr system down. i think frr old bugs still not fixed.

    should this bugs :

    https://forum.netgate.com/topic/154432/frr-multipath-relax-issue/4


  • i test again and sure the frr has bugs. when downlaod finshed frr and install, system will auto reboot and down.

    tell me how i do edit old frr config and i will try delete "bgp bestpath as-path multipath-relax" for test. where the old frr config files?

    New packages to be INSTALLED:
    	frr7: 7.3.1 [pfSense]
    	libssh: 0.9.4 [pfSense]
    	libyang: 1.0.130 [pfSense]
    	net-snmp: 5.7.3_20,1 [pfSense]
    	pfSense-pkg-frr: 0.6.7_4 [pfSense]
    	rtrlib: 0.6.3 [pfSense]
    
    Number of packages to be installed: 6
    
    The process will require 25 MiB more space.
    
    Proceed with this action? [y/N]: y
    [1/6] Installing libssh-0.9.4...
    [1/6] Extracting libssh-0.9.4: 100%
    [2/6] Installing libyang-1.0.130...
    [2/6] Extracting libyang-1.0.130: 100%
    [3/6] Installing rtrlib-0.6.3...
    [3/6] Extracting rtrlib-0.6.3: 100%
    [4/6] Installing net-snmp-5.7.3_20,1...
    [4/6] Extracting net-snmp-5.7.3_20,1: 100%
    [5/6] Installing frr7-7.3.1...
    ===> Creating groups.
    Creating group 'frr' with gid '168'.
    Creating group 'frrvty' with gid '152'.
    ===> Creating users
    Creating user 'frr' with uid '168'.
    Adding user 'frr' to group 'frrvty'.
    [5/6] Extracting frr7-7.3.1: 100%
    [6/6] Installing pfSense-pkg-frr-0.6.7_4...
    [6/6] Extracting pfSense-pkg-frr-0.6.7_4: 100%
    Saving updated package information...
    done.
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...Upgrading FRR Settings ... Nothing to do.
    done.
    Executing custom_php_resync_config_command()...done.
    Menu items... done.
    Services... done.
    Writing configuration... done.
    
    Socket error Event: 32 Error: 10053.
    Connection closing...Socket close.
    
    Connection closed by foreign host.
    
    
  • Rebel Alliance Developer Netgate

    Probably your filesystem is trashed or something else along those lines which would explain all of the symptoms. Watch the console, not ssh. Check for crash dumps after.

    That's highly unlikely to be a software issue.


  • I used a variety of methods to test and determine that the frr problem is caused, you let me try to turn off multipath,
    Because the same configuration file works fine on the pf2.4.5 system.

    please tell me how edit and turn off multipath...

    your said :"Though I'm not sure what specific issue you are talking about, there aren't any differences in the FRR package on 2.5.0 and 2.4.5-p1 except the 2.5.0 version is compiled with multipath enabled."


  • now show:

    photo_2020-08-15_01-28-27.jpg

  • Rebel Alliance Developer Netgate

    If it is related to FRR, then the crash is probably corrupting the filesystem and causing the other problems, so the other PHP errors you are seeing are still not from FRR.

    There is no easy way to disable multipath in FRR yourself, you'd have to setup a proper build environment and compile the package without that option.


  • If it is caused by other reasons, it is impossible to wait until the download of frr is completed, the problem only occurs when frr is installed.


  • <118>Starting CRON... done.
    <118>pfSense 2.5.0-DEVELOPMENT amd64 Fri Aug 14 01:01:27 EDT 2020
    <118>Bootup complete
    <6>ovpnc7: link state changed to UP
    <6>ovpnc3: link state changed to UP
    <6>ovpnc10: link state changed to UP
    <6>ovpnc9: link state changed to UP
    <3>rn_delete: couldn't find our annotation
    
    
    Fatal trap 12: page fault while in kernel mode
    cpuid = 2; apic id = 12
    fault virtual address	= 0x70
    fault code		= supervisor read data, page not present
    instruction pointer	= 0x20:0xffffffff80ecad66
    stack pointer	        = 0x28:0xfffffe008885e4f0
    frame pointer	        = 0x28:0xfffffe008885e5e0
    code segment		= base 0x0, limit 0xfffff, type 0x1b
    			= DPL 0, pres 1, long 1, def32 0, gran 1
    processor eflags	= interrupt enabled, resume, IOPL = 0
    current process		= 38625 (zebra)
    trap number		= 12
    panic: page fault
    cpuid = 2
    time = 1597433746
    KDB: enter: panic
    panic.txt0600001213715563622  7143 ustarrootwheelpage faultversion.txt0600006213715563622  7543 ustarrootwheelFreeBSD 12.1-STABLE 1424107d9b0(devel-12) pfSense
    

  • @jimp said in frr and system down:

    disable multipath in FRR

    why your can't disable multipath If the problem cannot be solved right now.


  • photo_2020-08-16_02-24-18.jpg


  • Again, multiple methods have confirmed that the problem of frr caused the system to crash.

    i have try delete any frr config parameter ,but the problem still exists.

    when i deleted full frr packge, pf system can running normal.
    So I once again confirmed that the system crash caused by frr.


  • i try full new install frr and not old config data, the bugs still here.

    textdump.tar.0