dhclient.conf config wird nicht angewendet


  • Servus Leute :)

    Zu meiner Situation :

    Mein ISP verlangt, dass ich beim PFsense folgenden String mitsende um damit ich eine öffentliche IP von Ihnen zu erhalten:

    interface "{interface}" {
    send dhcp-class-identifier "100008,0001,,pfsense 2.4.5";
    
    }
    

    Diesen String sollte ich unter dhclient.conf abspeichern. Den speicherort habe ich unter : /cf/conf gewählt. Dann beim Pfsense unter Configuration File Override den Pfad eintragen sowie den haken bei Configuration Override gesetzt.

    Nebst dem musste ich noch auf dem WAN die VLAN 10 konfigurieren.

    Nach etliche male hatt es bei mir nur 1 funktioniert und ich konnte den String auslesen mithilfe von tcpdump. Dannach hat es nie mehr funktioniert. Ich erhalte immer eine leere Datei ohne irgendwelche Informationen bei der Datei: dhcp-pcap Eine öffentliche IP habe ich leider auch nie erhalten.

    tcpdump -w dhcp.pcap -i em0.10 -n -e -s 65535 port 67 or port 68 und Wireshark:

    alt text

    Folgende Schritte habe ich versucht:

    dhclient.conf via Putty bearbeitet:

    alt text

    dhclient.conf via Winscp nochmals überprüft:

    alt text

    Bei Pfsense-> Interfaces->Wan den Pfad eingetragen sowie Einstellung aktiviert:

    alt text

    Schlussendlich habe ich noch bei Interfaces->Assignments -> VLAN die VLAN 10 erstellt und dem WAN Interface em0 zugeteilt.
    alt text

    Soweit alles gemacht, jedoch ohne erfolg, ich bin soweit gegangen das ich die Pfsense neu installiert habe.

    Wisst Ihr wieso es die Konfiguration nicht übernimmt ?

    Vielen Dank.

  • LAYER 8 Moderator

    Hallo!

    @Syosse said in dhclient.conf config wird nicht angewendet:

    Mein ISP verlangt, dass ich beim PFsense folgenden String mitsende um damit ich eine öffentliche IP von Ihnen zu erhalten:

    Finde ich erstmal aus 2 Gründen frech.

    a) Was geht die Nasen es an, was für eine Software ich einsetze? Und nen Versionsstring zu schicken ist kompletter Quark, sollst du das dann alle Version ändern oder wie? Blödsinn. Nen Custom oder Customer String würde ich ja irgendwo nachvollziehen können, aber OS+Version als String macht für mich keinen Sinn.

    b) Warum nicht wie andere auch einfach an der MAC Adresse festmachen, sondern explizit was mit custom DHCP Option einflicken, was wieder ein wenig nach Eigengewächs riecht und hinterher wissen das beim ISP wieder kaum Leute und man wundert sich plötzlich, warum die IP nicht mehr geht? Grenzwertig.

    Diesen String sollte ich unter dhclient.conf abspeichern.

    Hat der ISP dir das so geschickt oder was genau ist das? Denn so wie das ist, kannst du das sinnvoll nicht verwenden - da fehlen ja die ganzen anderen Angaben! Und {interface} ist hier auch nur Platzhalter, da müsste dann natürlich das richtige Interface (em0 oder em0.10 o.ä.) rein.
    Klang jetzt nicht so als ob das klar wäre, deshalb schreib ichs lieber nochmal.

    Den speicherort habe ich unter : /cf/conf gewählt

    Mach das lieber mal nicht. Ich würde erstmal mit einem File unter /root testen und das später dann ordentlich unter /usr/local/<irgendwas> mit dem "Filer" Package ablegen, sonst übersteht das keine Neuinstallation und wird auch nicht im Backup gespeichert!

    Zudem sieht dein normales Standard-File für dhclient so aus:

    interface "em0.10" {
            supersede interface-mtu 0;
            timeout 60;
            retry 15;
            select-timeout 0;
            initial-interval 1;
            >>> send dhcp-class-identifier "100008,0001,,pfsense 2.4.5";
            
            script "/usr/local/sbin/pfSense-dhclient-script";
    }
    

    Ich würde daher einfach hier nach dem initial-interval bei >>> dein "send dhcp-class" Part einfügen und die Datei dann speichern und via "configuration override" dann nutzen (natürlich ohne das >>>). Denn soweit ich mich entsinne wird bei Override ALLES überschrieben, ergo brauchst du auch die ganzen anderen Werte und nicht nur den einen, den dein ISP will, damit der DHCP Prozess auch klappt.

    Ich würde aber auch nochmal beim ISP nachschütteln und anfragen warum das unnötig kompliziert mit eigenem Textstring sein muss und warum da ne Version drinstehen soll, die spätestens in nem halben Jahr wieder überholt ist. Makes no sense to me.

    Wenn das mit dem File dann klappt, wie gesagt: "Filer" Package runterladen, Datei dort anlegen und mit richtigen Rechten ausstatten und damit sicherstellen, dass auch nach Neuinstallation das File automatisch angelegt werden kann. Auch wenn du dann nach Neuinstallation vllt. nicht direkt Internet hast (weil das File noch nicht da ist, da das Filer Paket noch nicht installiert wurde), hast du damit wenigstens den Inhalt schon sauber dokumentiert vorliegen und kannst das notfalls händisch anlegen bis das Package drauf ist.

    Einfacher/sinnvoller wäre es aber - auch um Probleme bei dir zu vermeiden - wenn dein ISP einfach auf den Kram verzichtet und statt dessen deine MAC oder bspw. auf einen Custom-Hostnamen besteht, den du beim DHCP Request mitsenden sollst. DA kann man sich ja durchaus was sinnvolles - oder auch komplexes wie eine UUID - einfallen lassen wenn sie dich damit unbedingt identifizieren wollen. Aber mit custom DHClient settings, die ich ggf. erst selbst anlegen muss bei Neuinstallation ist das schon denkbar unschön gemacht, um schnell wieder online zu kommen. Da muss es doch was einfacheres/besseres geben. :)


  • @JeGr

    Vielen Dank für deine Antwort.

    a.) Dort habe ich noch was vergessen zu ergänzen, die Version ist eigt. nur Platzhalter für mich.
    Also ich kann das auch frei lassen also die OS+Version fehlt weg.

    beim dhclient.conf handelt es sich eigt. um einen Foreneintrag den ich gefunden habe und dort entnommen habe.
    https://community.swisscom.ch/t5/Router-Hardware/PFsense-2-4-5-und-Medienkonverter-tp-link-MC220L-am-Swisscom/m-p/610486

    Super, ich werde es mit dem Standar-File gleich versuchen und auch gleich mit Filer die Datei anlegen und Rechte vergeben.

    Vielen Dank für die Infos. Ich werde zeitnah berichten und nochmals mit dem ISP Kontakt aufnehmen. Es handelt sich überigens um Swisscom Anbieter.

    Danke Gruss:)