Networking Problem with pfSense, Ubuntu and VirtualBox

  • Ubuntu Desktop 20.04.1
    VirtualBox 6.1
    pfSense 2.4.5
    2 Port Intel I350-T2 NIC
    Integrated Qualcomm single port NIC

    I’m attempting to get a pfSense VM functioning properly to use it as my residential firewall for training purposes. The reason for using a VM environment, I’m also adding TrueNAS Core and Plex Media Server to this Linux box.
    After installing Ubuntu and VirtualBox I setup a pfSense VM and all seemed well at the time. I connected my ethernet cabling properly and all seemed well as you can see in the following images:


    I have tried multiple Ubuntu NIC configurations while keeping the, known to work, pfSense VM NIC settings. The problem is that the pfSense DHCP is not allocating IPs to any of my LAN devices such as PC, laptop and streaming boxes.

    I’ve also tried different Linux and Windows VMs to access the web configurator without success. I even tried the static IP of on my workstation to access the configurator at to no avail.

    What am I missing concerning the network configuration?

    Any and all help is greatly appreciated!!!

  • This problem was resolved by changing adapter 2 to bridged and selecting 2nd port on the NIC.