Cannot access WebGUI after shutdown


  • I had to turn off my pfsense box to move it to my new server rack. When I restarted the system I cannot access the GUI. I can access it via SSH fine. When trying to restart the GUI with option 11 I get the message below. I also tried to restart PHP with no success.

    Restarting webConfigurator...
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to 0.0.0.0:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to [::]:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to 0.0.0.0:443 failed (48: Address already in use)\
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to [::]:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to 0.0.0.0:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to [::]:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to 0.0.0.0:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to [::]:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to 0.0.0.0:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: bind() to [::]:443 failed (48: Address already in use)
    Message from syslogd@pfSense at Sep 2 16:59:35 ...
    nginx: 2020/09/02 16:59:35 [emerg] 74951#100236: still could not bind()
    
    done.
    

  • Not sure, what else is using 443 on your setup, however, I'd generally recommend to use another port for the GUI to avoid conflicts with webservers.


  • How do I go about doing that in the shell?


  • @viragomann I went to the config file in the shell and there was no port listed for the webgui. It is now set on https and port 80. I rebooted the system but still does not work. Now when I restart the webgui from ssh the error I posted above is gone.


  • @Makaveli6103 said in Cannot access WebGUI after shutdown:

    It is now set on https and port 80

    Your browser will get mad at you.
    80 (or something else) is for http
    443 (or something else) is for https

    Mixing http and https with 80 and 443 and you have that typical 'shoot in the foot' situation.

    @Makaveli6103 said in Cannot access WebGUI after shutdown:

    How do I go about doing that in the shell?

    The quick and dirty :
    Use option 8, and type

    viconfig
    

    (you are using a text editor now - and this one does not behave as MS Word .... be informed).

    Look for the http or https port :

    3d868e97-1060-49b4-a2b5-c3ebd79c3689-image.png

    If the default 443 is used, there will be no value. Add something like "4334".
    Write, quit, and type

    reboot
    

    Now, your pfSense will answer on

    https://192.168.1.1:443
    

    (if https is used)

    Or, use the 2 option, which will re assign interfaces addresses, and will reset the GUI config back to port 80 - non https.

    Who is that other web server running on your pfSense ?
    Ask the other guy who also knows :

    sockstat | grep ':443'