Trunk many VLANs on SG-1100 & how to cleanup?



  • Hello everyone,

    I would like to trunk 10 VLANs out of the "LAN" port of my SG-1100. I have found videos (like this) about how to do it but they don't go till the end about cleaning up the original configuration. I watched this but its pre-SG-1100 and as far as I understand it, it shows how to disassemble the switch to create individual port. I probably don't understand it enough, my fault.

    So, I have few questions to double check ...to avoid bricking the device :)

    • Can I delete the LAN interface (which is tied to Network port: VLAN 4091) ?
    • Can I delete the VLAN "LAN" 4091 (interfaces->vlan 4091) ?
    • Can I delete the VLAN 4091 under switch -> Vlans, provided I replace it with 10 new vlans with are configured as "0t,2" ?
    • If the above is true then how to reconfigure the Port VID in the Switch -> Ports tab?

    If there is a tutorial anywhere about doing this please do let me know!

    Thanks a lot!

    Example of what I'm thinking of doing:

    Delete this? Screen Shot 2020-09-04 at 8.24.08 PM.png .. and delete this .. Screen Shot 2020-09-04 at 8.28.26 PM.png .. and delete this ... Screen Shot 2020-09-04 at 8.29.50 PM.png
    What to put here then? Screen Shot 2020-09-04 at 8.25.07 PM.png



  • Also, what's going on with this setting in the interface GUI? "Switch port" / "Use the selected Switch port as source for the port state changes" .. can I select port 2 for all the VLAN interfaces? because when I try it tells me: "This Switch port is already in used by another interface" .. so should I elect one of the VLAN in the trunk as "principal" and associate the port to that one and leave all the others blank? Or is this a bug?

    Thanks a lot!



  • Thanks to some help on reddit I was able to get this working. I haven't tested it well 100%, but so far it seems to be working fine. I post this here for reference. Please, if you think there is any issue let me know!

    a.png
    b.png

    Lastly, original LAN & OPT interfaces have been deleted. So have been the VLANs 4091 & 4092 under Interfaces > VLANs.

    However, regarding my second message, I think this is a bug and a ticket should be opened as I don't think we have one yet -- looking for confirmation! Please let me know. The issue: if more than one VLAN is trunked in a switch port, we can't select the same port multiple times on the interface configuration. This means that we can't correctly show those VLANs are down; only one can while the rest will always be green even if down.

    Screen Shot 2020-09-06 at 11.45.05 PM.png

    Thanks!



  • Opened up https://redmine.pfsense.org/issues/10890 for the Switch port issue.


Log in to reply