Unbelievable, nothing seems to work!



  • I saved a backup of my config and factory default this thing and without restoring the backup, i still can't get OpenVPN to work. User Auth only, No Certs, direct connection to WAN via UDP, nothing seem to work. I would appreciate if someone here can collaborate with ideas.

    Re: Help! OpenVPN settings will not connect no matter what I do



  • @rjamesm Have you followed any online guides? If not, this one works every time:

    Youtube Video

    You have to ultimately connect to your OpenVPN server from OUTSIDE your own network, but now that I say that, I believe it still works while inside. But, I know, you really do want it to work from the outside. Run thru the video guide and you should be good to go.

    Jeff



  • @akuma1x YES! That's what I've been following and it used to work now it doesn't I think there is an issue with 2.4.5-RELEASE-p1. I just factory reset the firewall and tried it from scratch and nothing. I can't get traffic through ports 1195 or 1194



  • @rjamesm said in Unbelievable, nothing seems to work!:

    now it doesn't I think there is an issue with 2.4.5-RELEASE-p1

    The OpenVPN has been severely tested since mars 2020.
    I would have to add : you and me and the other xxxx thousands of pfSense installation all share the same code.
    That is : everything is up to date ? Including the openvpn-client-export package , version 1.4.23_2 , which came out a couple of hours ago ?

    @rjamesm said in Unbelievable, nothing seems to work!:

    @akuma1x YES! That's what I've been following and it used to work now it doesn't I think there is an issue with 2.4.5-RELEASE-p1. I just factory reset the firewall and tried it from scratch and nothing. I can't get traffic through ports 1195 or 1194

    ba9ad52b-65e6-4a4a-bbc1-bd46240559fc-image.png

    change 1194 for 80 and UDP for TCP : now you can connect to the GU from WAN.
    Right ?
    Remove this edit right away after testing.



  • @Gertjan ok I found the problem. Yes you were on track with the port. I was using Cloudflrare DDNS to update the dynamic up address of the ISP happens that Cloudflrare will not proxy or even on grey out mode traffic Openvpn ports, even if you try to switch to their allowed ports IT WILL NOT WORK. I had to use another service such as no-ip and it started to work.



  • @rjamesm Can you get a static IP address from your ISP, or is it not cost effective?

    Jeff



  • @akuma1x No, the want to bill monthly extra for that. Plus I was thinking if would be safe to mask the IP through Cloudflrare but they don't support any traffic if it's not HTTP/HTTPS.


Log in to reply