Unable to connect to wireless SSID with VLAN



  • This post is deleted!


  • @Inxsible said in Unable to connect to wireless SSID with VLAN:

    ng winded post. I just thought all the above info is relevant. If there is any other information you need, please let me know.

    Here are my Firewall rules. They are the same for IOT, Work and Guest -- except changing the appropriate net and address

    e06a14d3-a658-4914-badf-af1ecca1f98f-image.png



  • You need more Port config.

    int gi1/0/4
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk allowed vlans add 4,7,5,10,11
    switchport nonegotiate
    exit

    check it with "show run int gi1/0/4"



  • @NOCling

    Please excuse my utter stupidity !!! The issue was PEBKAC.

    I set up port 4 as the trunk between switch and AP --- but the label on my wall plate corresponds to the patch panel ports. I had forgotten that I had connected port 4 from Patch Panel to Port 7 in the switch because the patch cables were stretching too much when using the lower row of ports in the switch -- so I am only using the upper row / odd port numbers. If the need ever arises, I will get another patch panel later.

    After setting up port 7 as the trunk between switch and AP, I am able to connect to these SSIDs and also get the correct IP addresses. I am really sorry to have wasted your time.

    However, I am no longer getting access to the internet when I am connected to the SSIDs with VLAN ids.... Do you see anything wrong with my Firewall rules in the above post?



  • @Inxsible said in Unable to connect to wireless SSID with VLAN:

    However, I am no longer getting access to the internet when I am connected to the SSIDs with VLAN ids.... Do you see anything wrong with my Firewall rules in the above post?

    I had to add Outbound NAT rules because I have mine set up as Manual. Once I added those and the allow rule to access the firewall for DNS, I was able to access the internet from the devices connected to the VLANed SSIDs


Log in to reply